cannot play DVD


I am running 11.1 and cannot play a dvd disk.I tried all multimediaplayers and already installed all restricted multimedia formats. The system is updated and i got the right repositories (checked)
Anyone the same problems ?


and we can’t help you much if you don’t provide more information, like which players you used, what messages you get, etc

try from console: mplayer dvd:// -dvd-device /path/to/your/dvd/device (usually /dev/dvd)

“does not work” is not a problem description. it is a problem recognition

I’am very sorry, of course.
Tried this :

guy@linux-6ynp:~> mplayer dvd:// -dvd-device /dev/dvd
MPlayer dev-SVN-r29116-4.3-openSUSE Linux 11.1 (i686)-Packman (C) 2000-2009 MPlayer TeamCan't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvd://.
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Couldn't open DVD device: /dev/dvd (Permission denied)
No stream found to handle url dvd://

Exiting... (End of file)

I will try all my players and post the error messages :wink:

Kaffeine reports : permission denied and no plugins
Mplayer : "unsupported pxel format -1

seems a device permissions problem, try this as root on console: chmod 660 /dev/dvd

also you may want to add yourself to the video group in Yast user settings

Done, but problem remains (also tried an different dvd player)
Kaffeine reports :

16:01:48: xine: cannot find input plugin for MRL [dvd://]
16:01:48: xine: input plugin cannot open MRL [dvd://]
16:01:48: xine: found input plugin : DVD Navigator

just as a double check - can you try to play a music CD

Negative. Same error report concerning permissions.Could the system be corrupted since i did the install with the life cd and not the complete dvd.i have 3 years experience with ubuntu and i tried several other distros (mandriva and pardus) but i find opensuse very interresting. I would like to change my system into a triple boot with ubuntu opensuse and xp. Perhaps I should consider a whole new install of ubuntu and opensuse and this time use the DVD.Perhaps because I used the livecd, I got this problems with multimedia.

Just tried a audio cd on one of my other systems (ubuntu 9.04) no problem here :wink:
Same with the dvd. The system recognise the disk immediately and opens the appropriate program :slight_smile:

that makes things clearer - it is a permission problem.

if you go into yast and select the user settings, then add yourself to the ‘disk’ and ‘cdrom’ groups. Then re-log in and everything should work OK.

I reorganised my partitions to get a triple boot system (winxp, ubuntu, opensuse)I’ll use the dvd to install opensuse now. First thing to do after install and update is to check dvd and audio cd remembering your advise. Keep yoy informed. Thank you very much :wink:

“disk” and “cdrom” groups added.
audiocd failed : amarok reports : (have to translate it for you, this system is in Dutch)

can't start the next proces, can't make io-slave; Klauncher answered : unknown protocol "audiocd"

DVD works fine with Kaffeine. Perhaps I shoud install another program to play audiocd

try kscd for playing a CD

kscd works, but sill no sound (sound check ok)
Kaffeine starts DVD but when i choose another chapter : “error reading NAV pachet” “posseible you haven’t enough rights”
I added the following groups to my account : audio, cdrom, disk, floppy,video, dialout"
Should i add some more ?

Have you installed openSuse and run the autoupdate immediately?
I have a similar problem with audio cds and dvds with the latest kernel updates. No amount of adding myself to different groups allows an automount.

Have you tried mounting the disc as root: (mount -t iso9660 /dev/dvd /mnt say)?

Try rolling back to the original kernel (yast2>software) and then choose to downgrade the kernel.
If this works, then you also have a problem with the kernel with your hardware.
I found the easiest was to create an entry in /etc/fstab for the dvd mount.

I found the easiest was to create an entry in /etc/fstab for the dvd mount.

I did so and the errors playing dvd seem to have vanished.
Just have to test the sound of an audio cd. Let you know

Great. To refine the mount point, as root create a directory /media/dvd say.
Now (also as root) edit /etc/fstab and add an entry:
/dev/sr0 /media/dvd iso9660 ro,user,noauto,unhide 0 0

(If you do fdisk -l in a terminal as root, it should tell you the name of your cd/dvd drive - substitute this name for sr0.)

This will automount any disk you put into the drive.

DVD plays normal (Kaffeine) Only when I try to fastforward the movie i get an error message ( not enough rigths or no dvd placed) when i resume the playing everything normal. Strange.
cd player starts but no sound and no sign of the cd in dolphin. I altered /etc/fstab as you proposed :

/dev/disk/by-id/ata-WDC_WD5000AACS-00G8B0_WD-WCAUF0346101-part6 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-WDC_WD5000AACS-00G8B0_WD-WCAUF0346101-part5 /                    ext3       acl,user_xattr        1 1
/dev/sr0             /media/dvd           iso9660    ro,user,noauto,unhide 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

This is the outcome of “fdisk -l” as root :

Schijf /dev/sda: 500.1 GB, 500107862016 bytes
255 koppen, 63 sectoren/spoor, 60801 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes

Schijf-ID: 0x000bdf18

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1               1        5191    41696676   83  Linux  
/dev/sda2   *        5192       10551    43054200    5  Uitgebreid
/dev/sda3           10552       60801   403633125    7  HPFS/NTFS 
/dev/sda5            5192       10294    40989816   83  Linux     
/dev/sda6           10295       10551     2064321   82  Linux wisselgeheugen

Schijf /dev/sdb: 81.9 GB, 81964302336 bytes
255 koppen, 63 sectoren/spoor, 9964 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes

Schijf-ID: 0xb9aeb9ae

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdb1   *           1        9964    80035798+   7  HPFS/NTFS

with the audiocd in place. So no sign of it.
Audio test also seems ok. As I said earlier, have 3 years experience with ubuntu and after a clean install and putting all multimedia in place, everything worked out of the box. Could there be something wrong with the kernel updates ??

OK then. I take it you can read a normal data disk in the drive and you only have one drive?
If so, try replacing the ‘sc0’ with ‘dvd’ in the fstab. (Make sure you don’t have a disc in the drive when you do this)