cannot play dvd movies


when I try to open a dvd movie in kaffeine, the dvd won’t play. I allready performed some research on this forum, but was not yet able to solve it. In yast, I have made myself member of all groups, including cd rom (is being member of all groups bad??). Also I have multimedia codecs installed. (including lib…css, vlc,…).

I receive a xine error: cannot read the source - not enough rights. (/dev/dvd).

Also: no plugin found for this source.
21:20:43: xine: cannot find input plugin for MRL [dvd://]
21:20:43: xine: input plugin cannot open MRL [dvd://]
21:20:43: xine: found input plugin : DVD Navigator
21:20:12: xine: found demuxer plugin: image demux plugin
21:20:12: xine: found input plugin : file input plugin
21:20:06: xine: cannot find input plugin for MRL [dvd://]
21:20:06: xine: input plugin cannot open MRL [dvd://]
21:20:06: xine: found input plugin : DVD Navigator

Again, a mix of Videolan and Packman packages. Disable the Videolan repo, reinstall all libxine packages, ffmpeg, all libdvd…, libav…
Leave only libdvdcss installed from Videolan, even pick vlc from Packman.

At first sight, I don’ see any VideoLan repo’s (several opensuse repo’s and 2 packman repo’s).

I removed all files you mentioned (but do not know if I removed any “VIDEOLAN” repo) and reinstalled them from packman. DVD-playback now works, but it falters all the time (so no fluent playback). I tried this with several dvd’s. I dont have this problem with avi, mpeg,… files and video card drivers are correctly installed (nvidia Geforce 7300).


What is the age of your PC? Is this still with kaffeine? If kaffeine, do you have the xine sound engine selected? Have you tried other DVD players?

On our old Fujtisu Siemens M7400 laptop (Intel graphics, 1.5 Ghz Intel centrino CPU) my wife discovered that with the packman packaged vlc, video DVDs do not play back well. But they playback ok with kaffeine and smplayer.

You mention you have a nVidia Geforce 7300. What graphic driver are you using? Vesa? nv (openGL) ? or nvidia (proprietary) ? The driver in use will be coded in your /etc/X11/Xorg.conf file.

I tried playback with kaffeïne, xine,…
The drivers I’m using are Nvidia proprietary. My computer is a Intel(R) Pentium(R) D CPU 2.80GHz.

Thanks a lot

How certain are you that the DVD is good? Have you tried other DVDs?

How certain are you that you have this fixed to be pure packman?

You could try checking your system against this:
Check your multimedia problem in ten steps - openSUSE Forums

You can also follow this guide to get multimedia working in OpenSUSE 11.1.
I found this guide to be a life saver. And I personally use VLC media player for my DVD needs. I have a launcher with the command “vlc -f /dev/sr0” so it will play my DVD full screen in KDE4.

I see re-reading the thread that you tried several DVDs. Still, I would like to do a check to confirm you have the proprietary driver. I’ve read of users who thought they had it installed, but missed the important step that adds the proprietary driver to the xorg.conf.

What is the output of:
grep -i driver /etc/X11/xorg.conf
Do you get “nvidia” next to driver?

And if using a proprietary graphic driver, which version? Have you tried other versions (in case you have a compatibility problem)?

Sorry for the late respons:

this is the output:
Driver “kbd”
Driver “mouse”
Driver “nvidia”