Cannot play audio through bluetooth headphones

I have a pair of Bose 35 II bluetooth headphones. They also have a microphone for use with mobile phones etc.

I can pair and connect to the headphones, they are listed as a connected audio device in the KDE Plasma Bluetooth app. But there is no sound through the headphones, the sound comes through the built-in sound card in the laptop.

If I use pavucontrol the bluetooth headphones are not listed in the “Configuration” tab.

I I check in Configure Desktop/Multimedia/Audio and Video/Device Preferences the headphones are not listed there either so there is no way to prefer them over any other output.

I also use a pair of Bluetooth speakers. I have no problem pairing and connecting to them and playing audio through them. They are listed in pavucontrol.

What can I do to fix this?

My setup is;

  • OpenSUSE Leap 42.3
  • KDE Plasma 5.8.7


same problem here with Leap 15.0 beta and Gnome. But sometimes it’s working, so I can choose my headphones to play music, but most of the time it doesn’t.

It seems to be better when I unpair the bluetooth device first before I try to connect them again. But it’s tricky. I thought the problem could be PulseAudio 11.1 but now I am not sure. Do you have TLP installed?


With respect - I don’t think they are properly paired.

I have a set of Bose Bluetooth Soundsport headsets paired with my openSUSE-42.3 on my Toshiba ultra book running KDE. Pairing was difficult. It took over a dozen tries. When they finally succeed in pairing, I get an audio voice which is a Bose Sound sport feature saying paired (this is true for all the headset’s pairings). Initially while KDE was telling me it was paired, the headset was giving no audio (voice) confirmation of being paired to my Toshiba ultrabook. And in indeed it was not paired. There was no indication in pavucontrol as you note.

After trying many times, (removing the headphones from KDE and adding back), I finally got the Boseheadset to give me an indication ‘paired to Toshiba’ . And then they appeared in pavucontrol. See below.](ImageBam)

The Toshiba Ultra book gave me the above many times - saying it was paired, but in fact it was not.

Finally after pairing succeeded, I obtained the following in pavucontrol](ImageBam)
Configuration Tab
Playback Tab


I think you are right. When I remove the pairing and start over again I notice that the headphones do not report that they are paired with the laptop. When I do the same with my mobile phone the headphones tell me they are paired with the mobile phone. Plasma on the other hand do think it is paired with the headphones, I just cannot use them for anything since they do not show up as an output.

I tried to remove the (incomplete) pairing and pair again a number of times without success. Sometimes Plasma doesn’t report any errors at all but a few times Plasma reports an error when trying to pair.

I will simply give up on this now, I use the headphones with my mobile phone instead. It isn’t worth the effort trying to get this working. It’s a pity though, the headphones are really nice and it would have been great to use them with my laptop.

Thanks for the help anyway!

As you say - its a pity. I tried a dozen times (in the space of about 15-minutes) before I got it to work the 1st time. Most the time when it failed (to give me the audio confirmation in the headphone saying ‘pairing to Toshiba’ ) I would delete any entry in KDE for the device, and try again … re-launching the wizard when option provided.

After I FINALLY got it to work the 1st time - it has now paired IMMEDIATELY in any subsequent attempts. It was the 1st attempt that was so difficult.

Thanks this solves my problem, I’ve been stuck on this for a bout 2-3 days and reading this thread make it works I can use it now on my two portable Bluetooth speaker here and this alternately one for movie / gaming and music.

I had the same problem with my Blitzwolf Bluetooth headset on opensuse Leap 15 running KDE Plasma.

I tried everything i found from Google searches and none of them worked for me.

Then all of a sudden I remembered I had a Ubuntu 18.10 USB lying around, and I tried the headset in it, and it worked.

So, I immediately removed the headset from Bluetooth paired list, installed Gnome in openSUSE Leap 15 and paired the headset again without any of the manual configurations, and it worked.

May be there is a neglected bug which is preventing Bluetooth headsets working KDE Plasma.


with the help of these instructions and hints I just got the Bluetooth connection up and running to my DigitalRadio 100, which is connected as input to my HiFi-system.
I am using openSUSE 15.1 with KDE on a TUXEDO-laptop.

Thus I can now hear the sound of movies, mediatheks, … on my HiFi-system.