Cannot Open Winmail.dat file with tnef.

I have been sent a winmail.dat file attachment and cannot open it. I am confused first by the options for tnef:- tnef, ktnef, ktnef5. I assume the tnef is simple command line and the others are associated with KDE desktop.
Sadly none are working. I get messages from Thunderbird that there is no application installed that can open files of the type TNEF message even though I have ktnef installed.
If I run from console I get message

tnef: qbemail.pdf: Could not create file: File exists

This suggests to me that the attachment is a pdf (which is what I need) wrapped up as if it were a message from Outlook.
Is there any way I can sort this out please?

Budgie2

In this case, MS provides the answer: https://support.microsoft.com/en-gb/help/278061/email-received-from-a-sender-using-outlook-includes-a-winmail.dat-attachment

Then I would suggest to save the file to disk, run ktnef manually, click on “Open” and select the file.

I cannot help you more though, as I never in my life had the “luck” to receive (or even see) a Winmail.dat file…:wink:

Hi John and thanks for taking the trouble to post but try as I might I couldn’t find the answer to my question in your reply. The MS website advice was

To resolve this issue, ask the sender to re-send the message in plain text format.
.
As you can see from my post, the content was an attachment in pdf format and it was not possible for the sender to put into plain text.
The sender was however willing to help and sent the attachment from his android phone so I received a pdf file as intended.
I had hoped there was a linux solution but not found it yet.

Thanks for the reply and suggestion. Already tried that. Could see bits of the file in amongst garbage but nothing resembling the VAT invoice I was seeking.
Problem solved thanks to android phone!!!