Cannot open files over a smb network connection

openSUSE 42.2 (x86_64)
VERSION = 42.2
CODENAME = Malachite
Samba version 4.4.2-9.1-0-SUSE-SLE_12-x86_64

New SusE user here, and I’m having an issue connecting to Windows shares - Server 2012R2.

I can successfully connect to the windows share using a windows machine, and it also successfully worked using Linux Mint.

I have connected to the share using Dolphin, I get prompted for my domain credentials, I eneter them and then I see all the file and folders and drill down through them just as one would expect.


However, when I try and open a PDF it fails, with the following message
“Could not open smb:// Reason: The file or folder smb:// does not exist.”

However, I can copy the file over and then open it, so it is when I try and open the file over the network share.

The permissions on the windows server side look fine.

Is there a fix for this?

My suggestion would be to mount the smb share locally. That way the OS will see the files on the smb share like any other file.

sudo mount // /mnt/windows -t cifs -o username=foo,password=bar

Obviously, replace what I have with whatever works for you.

Thanks, that worked great.