Cannot open any programs

Hi, I’m on latest LEAP KDE update, dunno what happened exactly, but all of a sudden I cannot open any program, (including konsole, yast, etc).Tried older snapshot but the problem insists.Any idea here please?

I had this same problem, in my case it was caused by Plasma and kmozillahelper.

Each time it restarts, Plasma reopens your programs. It also restarted kmozillahelper which was also started anew from Thunderbird and Firefox. After some time it reached the maximum number of processes.

  1. End 1 or 2 programs you are running.
  2. Open ksysguard (system monitor)
  3. Select the treeview on the processes tab
  4. Select all kmozillahelper processes that are not a direct child of Firefox or Thunderbird
  5. Send them the “TERM” signal (click right, choose send signal, choose TERM)
  6. Repeat this every now and then.

Of course 1 and 2 only need to be done if you are not already running ksysguard. And 6 is only necessary after restarts where you left Firefox and/or Thunderbird running.

thanks a lot, it worked:)

Rather than restore previous session, you might want to consider starting KDE with an empty session, or if you do wish to restore, to specify applications to exclude from being restored.

Both options can be found at:

(KDE) System Settings -> Startup and Shutdown -> Desktop Session

I know that and that’s what I do for years, “problem” is that Thunderbird and Firefox are two of the applications I like to restore at start. Never had this bug before and I’m a KDE/Firefox/Thunderbird user for many years, guess I was lucky till now :see_no_evil:

When such a thing changes for the worse after an update, do you not feel the urge to file a bug report? That will often cure the problem for you, cure it for others also and improve the openSUSE distrubution and/or theKDE software and/or Linux in general.

I do. However, somebody got there before me. The bugzilla bug no = 1199941](1199941 – kmozillahelper uses up all X clients given enough logout/login cycles).

Thanks for posting the link to the bug report. Now others can contribute when needed.

I’m seeing this too after resuming a session from the lock screen or monitor timeout, probably when I left firefox running.
KDE is NOT set to restore the last session at startup, but firefox is set to reopen all previous tabs.

I also noticed that if I can open a terminal (konsole) I can run a graphical application from it, when I couldn’t open it by clicking it’s icon on the desktop/menu.

I have the systemloadviewer plasmoid installed in the panel, and it shows normal memory use levels (about 4 of 32 GB), and no swapping.

Next time it occurs I’ll see if I can open ksysguard, or I can always switch to a tty (is that the correct term?) and run top, or atop, or htop, or whatever is the tool “du jour” :stuck_out_tongue: