cannot mount volume

Hi All
Using SUSE 11 here and a newbie
When I try to mount my external USB 2 drive, I get an alarm cannot mount. Under details advises due to unclean shutdown. Advises to use Safely remove devices icon in task bar, there isnt one!
any idea’s?
Also advises an entry into command line if not using windows, but i find it very difficult to distinguish the spaces if there are any to get the entry right.

graham@linux-adyl:~> mount-t ntfs-3g/dev/sdb1/medial/WD USB2-o force

Tried it but alarmed
bash: mount-t: command not found

Thanks in advance

It’s mount -t and not mount-t
The corrent line should be

mount -t ntfs-3g /dev/sdb1 /medial/WDUSB2 -o force and not mount-t ntfs-3g/dev/sdb1/medial/WD USB2-o force.

You need to use spaces and the mountpoint /medial/WDUSB2 needs to exist as a folder. Also try to avoid spaces in the names.


In order to mount a file system stored in a given device on a mount point in the system directory hierarchy, you need to adhere to the following syntax:

mount [options] device mount-point

In your case, assuming the usb device only contains a single partition where a ntfs file system is stored, being that identified by the system as /dev/sdb1, you will do:

mount -t ntfs -o ro /dev/sdb1 /media/WD

Notice that in the above command I am also assuming that a directory named WD exist beforehand hanging from /media.
If you want to mount the fs in write mode, use -o rw instead of -o ro

Keep in mind also that ntfs write support in linux is still not 100% reliable.

There are quite a few scenarios that can prevent the fs be mounted: file system corruption, bad options, incorrect mount point, unsupported file system. Double check that your fs matches the options specified in your mount command.

Find more options and details in the mount man pages:

> man mount

Verify the external fs has been mounted by running:

> df -v

By the way, mind the blank spaces between each keyword in the command. When in doubt, read the man pages.

Hope this helps.

hi Both
Thanks for your reply

Strange, If I hot reboot to suse after being in xp and leave the usb disc running its fine???

Comments pls as this really confuses me