Cannot mount NFSv4 volume in 12.1

Since paste/MMB does not work here but pastes to the browser :mad: again in short:
NFSv4 share on debian server.
SuSE = client, dont work.
Ubuntu, same machine: always worked, still does.
I get:
shodan:/mnt/nfs # mount
media/mount.nfs:
mounting 192.168.0.2:/srv/nfsv4/media failed, reason given by server: No such file or directory
fstab has:
192.168.0.2:/srv/nfsv4/media /mnt/nfs/media nfs auto 0 0
exportfs on server lists it fine. What’s wrong?

Hi, welcome here

Please separate output from your writings by putting the output between CODE tags.
Cause could be that the folder /mnt/nfs/media does not exist on the client. Another one: on my clients it’s “defaults” in the fstab line, instead of “auto”.

Perfectly exists. chmod’ed it 777 just to be sure, still no go.

Still does not work after taking down the firewall…
Don’t even see rpc.mountd calls on the server’s logs.

Read this thread if you haven’t already done so

http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/475956-mounting-nfs-not-working-boot.html

In particular, user please_try_again has a workaround for those impacted by systemd:

http://forums.opensuse.org/english/other-forums/development/programming-scripting/469832-running-commands-depend-process-being-started-after-local.html

You may also want to consider using autofs (instead of fstab entry) to handle NFS mounts.

Works well for some:

http://forums.opensuse.org/english/get-technical-help-here/network-internet/475789-nfs-differences-traditional-netwrking-network-manager-3.html
http://forums.opensuse.org/english/get-technical-help-here/network-internet/465707-autofs-causes-computer-freeze.html

So far tried the two below (the editor of this forum drives me insane), both did not work

"create the following file: "
/etc/systemd/system/<mount-unit-name>.mount
[Unit]
Description=<mountpoint>
Wants=rpc-statd.service
After=network.target rpc-statd.service

[Mount]
What=<server>:<share>
Where=<mountpoint>
Type=nfs

Did not work, same error

Alternatively, you can mark these entries in /etc/fstab with the
x-systemd.automount and
x-systemd.device-timeout=# options (see
systemd.mount(5)). Make sure that if you also include
defaults as a mount option, that you override the implicit
auto with
noauto.

Sorry, I can’t help with systemd services, my suggestion only related to replacing the fstab entry with the automounter (and associated autofs config files).

https://wiki.archlinux.org/index.php/Autofs#NFS_Network_mounts

On Thu, 28 Jun 2012 20:26:04 GMT, deano ferrari
<deano_ferrari@no-mx.forums.opensuse.org> wrote:

>
>You may also want to consider using autofs (instead of fstab entry) to
>handle NFS mounts.
>
>Works well for some:
>
>http://tinyurl.com/79po7bb
>http://tinyurl.com/7p7tmum

Not that all my servers or clients are openSUSE 12.1, but autofs works
pretty well for me. My versions are rather a bit older but no worse than
11.1. And i have had many issues NFS V4, i don’t use it.

?-)

On Fri, 29 Jun 2012 22:16:03 GMT, DexterF
<DexterF@no-mx.forums.opensuse.org> wrote:

>
>So far tried the two below (the editor of this forum drives me insane),
>both did not work
>
>"create the following file: "
>/etc/systemd/system/<mount-unit-name>.mount
>[Unit]
>Description=<mountpoint>
>Wants=rpc-statd.service
>After=network.target rpc-statd.service
>
>[Mount]
>What=<server>:<share>
>Where=<mountpoint>
>Type=nfs
>
>Did not work, same error
>
>Alternatively, you can mark these entries in /etc/fstab with the
>x-systemd.automount and
>x-systemd.device-timeout=# options (see
>systemd.mount(5)). Make sure that if you also include
>defaults as a mount option, that you override the implicit
>auto with
>noauto.

Personally, i can’t stand any web interface to usenet that i have ever
seen (over 30 so far). Then again i have usenetted since 1983. What i
would likely respect is a web interface that really respected usenet
norms. gaggle gropes sure ain’t it. I hit this place via nntp and a real
news reader (agent).

BTW i use automount with nfs just fine, but the settings are just a bit
fiddly. I do not use nfs v4 it gets to fiddly.

?-)