Cannot logout in Gnome

Hello Folks,

Has anyone else had difficulty logging out of gnome. When I try, I get to a black screen and a non-usable cursor/arrow that doesn’t respond. I tried a different kernels and initially that seemed to work, but then the problem re-emerged.
I saw in a thread that a polkit may have changed recently and that might be a problem? I’m really not sure if that is even related. I have not been able to find anything in bugzilla regarding this.


Not running a proprietary driver, eg Nvidia or Catylast? What happens if you press ctrl+alt and hit backspace twice?

I’m having this issue as well.

Intel driver on a macbook. Can’t seem to recover from the black screen.

No proprietary driver, just intel.

I tried the ctrl+alt backspace 2X and nothing. To resolve the black screen and unresponsive cursor, I have been using the alt+prtsc and reisub method.

Perhaps there is something In YAST I can adjust?

I have a Thinkpad T440P.

I thought those machines are optimus (as in dual gpu’s)?

I have intel sandybridge with Tumbleweed 20151201 and no issues, what if you create a test user, is the issue duplicated?

Not sure if this helps, but my issue occurred just agter a fresh install. One thing I did was, on first login after install, manually install the xfce pattern (I forgot to select xfce during installation) and uninstall the gnome pattern. Then I hit logout since at the time I was in Gnome, and that was the first time I experienced the black screen.

I thought maybe something could have happened when I removed Gnome, but I always see the first login screen on boot, it just seems to manifest when I logout to create a new session.

Interestingly, It seems to be sporadic. Well, it may work properly once.
I switched to auto login and it worked the first time I logged out. When I tried to log back out after that, it gave me the black screen unresponsive cursor again. I switched back to password login and it failed. I have yet to duplicate a positive test.

I will try a test user and post back. Can a test user be deleted after one is finished?


Yes, you can delete the user, it will also remove the home directory creates.

Did you confirm it’s not dual graphics cards?

Thanks for the info regarding the test user.

Yes for the graphics card. I just have intel. No optimus, if that is what you mean.

Graphics: Card: Intel 4th Gen Core Processor Integrated Graphics Controller
Display Server: X.Org 1.18.0 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.01hz
GLX Renderer: Mesa DRI Intel Haswell Mobile
GLX Version: 3.0 Mesa 11.0.5

The logout function used to work, Something must have changed or I did something (:slight_smile:

My test user fails as well.
Is there a way to logout via the terminal, perhaps it will give me some useful info.
Is there a log somewhere that I can check?

Did you solve your problem? I have the same issue…

Unfortunately, no. :frowning: I’m out of ideas, except to file a bug report.


I filed a bug report for this issue.



Thanks Bjorn!

(See Bug report above.)