Cannot loging to Wayland KDE Plasma


I tried to login with Wayland in KDE Plasma.
On the screen only a cursor appears and the hole system looks to have been crashed.
How could i fix that?

Thanks in advance!

And your videocard is?
And why Wayland ?
FWIW, I tried it a couple of times, but IME and on my laptop Xorg is doing the job much better.

  1. GeForce GT 440/PCIe/SSE2
  2. I just logged with wayland to try it. With x-server it works fine.
    It is not emergency to fix it.
    If it is difficult to be solved i can skip this problem.

That is a pretty old video card, I doubt whether Wayland will run nicely on it anyway.

OK! Thanks.

Plasma Wayland is still a work in progress.

It works fine here, with Intel graphics – except for what doesn’t work.

The workspace selector icon does not show up. Some windows start in the wrong location.

So, okay, you are missing a chance to play with Wayland. But you aren’t missing much. Plasma on Xorg works much better at present.

According to LEAP 15 notes, you have to be running the Nouveau graphics driver…
That plus other misc Wayland stuff…

A long time ago when Wayland was far more experimental than now, I ran it with the Enlightenment Desktop on a 2003 vintage laptop to try to experience the full extent of Wayland’s graphic capabilities… and although Wayland installed and ran, there was plenty of latencies due to the extreme graphics.