Cannot login to Samba shares

I am attempting to use openSUSE as my primary server in my home. Unfortunately, I cannot access the Samba shares. I have gone through everything I know to go through and they are not accessible.

I use the username and password that is setup for each user but it seems that it is not the same password for a samba share. I can share files via sftp, ftp, and so forth but not samba.

I tried setting up a password via CLI with the command smbpasswd but get the error:
machine 127.0.0.1 rejected the password change: Error was : NT_STATUS_RPC_PROCNUM_OUT_OF_RANGE.

How do I make openSUSE use usernames and passwords from the user accounts?

Any help would be greatly appreciated.

-Nathan

When in doubt, you must visit these sites below:

  1. Index of /samba/docs/man
  2. openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna
  3. Samba SWAT (Samba Web Administration Tool) Setup for openSUSE - Blogs - openSUSE Forums

Perhaps something here will be useful to you.

Thank You,

A couple of questions to get more background:

  • What version of openSUSE are you using
  • Did you run the smbpasswd command as root, and exactly what command did you run?

what response do you get from these commands (run as root):

  • /etc/init.d/smb status
  • /etc/init.d/nmb status
  • pdbedit -L
  • zypper se sysvinit-init systemd-sysvinit

And can we have a look at your file smb.conf please

Bad me… I am running openSUSE 12.1

I am not running a domain controller, I am looking to do simple shares.

I have gone through many of the help documents, done a lot of Googleing and have been unsuccessful in being able to enter my password to access a share. I created the share using Dolphin.

To be honest, after a few hours of dinking around with this, I have become impatient and irritated so I am hanging my head low and asking for help now. I really am not that much of a noob, just easily frustrated with SAMBA as it appears to be one thing in Linux that I can’t master and drives me insane. If I could avoid using SAMBA, I would never use it again… ever…

I executed “smbpasswd” as user.

With that said, here is output from smb.conf:

# cat /etc/samba/smb.conf 
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2011-11-02
[global]
        workgroup = WORKGROUP
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = Yes
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        domain logons = No
        domain master = No
        netbios name = Prime
        security = domain
        usershare max shares = 100
        wins support = Yes
        idmap gid = 10000-20000
        idmap uid = 10000-20000
        ldap suffix = 
[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes
[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
[users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
[groups]
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
[printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

## Share disabled by YaST
# [netlogon]
#       comment = Network Logon Service
#       path = /var/lib/samba/netlogon
#       write list = root

I appreciate any help you can lend me.

-Nathan

I should also note that I have added users using this method:

sudo smbpasswd -a william

On 11/25/2011 5:26 PM, futureboy wrote:
>
> Bad me… I am running openSUSE 12.1
>
> I am not running a domain controller, I am looking to do simple
> shares.
>
> I have gone through many of the help documents, done a lot of Googleing
> and have been unsuccessful in being able to enter my password to access
> a share. I created the share using Dolphin.
>
> To be honest, after a few hours of dinking around with this, I have
> become impatient and irritated so I am hanging my head low and asking
> for help now. I really am not that much of a noob, just easily
> frustrated with SAMBA as it appears to be one thing in Linux that I
> can’t master and drives me insane. If I could avoid using SAMBA, I
> would never use it again… ever…
>
> I executed “smbpasswd” as user.
>
> With that said, here is output from smb.conf:
>
>
> Code:
> --------------------
> # cat /etc/samba/smb.conf
> # smb.conf is the main Samba configuration file. You find a full commented
> # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
> # samba-doc package is installed.
> # Date: 2011-11-02
> [global]
> workgroup = WORKGROUP
> passdb backend = tdbsam
> printing = cups
> printcap name = cups
> printcap cache time = 750
> cups options = raw
> map to guest = Bad User
> logon path = \%L\profiles.msprofile
> logon home = \%L%U.9xprofile
> logon drive = P:
> usershare allow guests = Yes
> add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
> domain logons = No
> domain master = No
> netbios name = Prime
> security = domain
> usershare max shares = 100
> wins support = Yes
> idmap gid = 10000-20000
> idmap uid = 10000-20000
> ldap suffix =
> [homes]
> comment = Home Directories
> valid users = %S, %D%w%S
> browseable = No
> read only = No
> inherit acls = Yes
> [profiles]
> comment = Network Profiles Service
> path = %H
> read only = No
> store dos attributes = Yes
> create mask = 0600
> directory mask = 0700
> [users]
> comment = All users
> path = /home
> read only = No
> inherit acls = Yes
> veto files = /aquota.user/groups/shares/
> [groups]
> comment = All groups
> path = /home/groups
> read only = No
> inherit acls = Yes
> [printers]
> comment = All Printers
> path = /var/tmp
> printable = Yes
> create mask = 0600
> browseable = No
> [print$]
> comment = Printer Drivers
> path = /var/lib/samba/drivers
> write list = @ntadmin root
> force group = ntadmin
> create mask = 0664
> directory mask = 0775
>
> ## Share disabled by YaST
> # [netlogon]
> # comment = Network Logon Service
> # path = /var/lib/samba/netlogon
> # write list = root
>
> --------------------
>
>
> I appreciate any help you can lend me.
>
> -Nathan
>
>
Nathan;

“security = domain” should only be used on a member sever of an NT or Samba domain. Remove that
line from your /etc/samba/smb.conf and let Samba go to the default: security = user. I think it
would be best for you to read and carefully follow this HowTo:

http://opensuse.swerdna.org/suselanprimer.html

The above covers not only your smb.conf but also adding users and the firewall.


P.V.
“We’re all in this together, I’m pulling for you” Red Green

Thank you very much! You are the best! I am so relieved it’s working! I will read up on the site you recommend. I do have to learn more about all this SAMBA stuff if I plan to be useful.

Thanks again!