Cannot login to GUI after zypper dup

HI,

FYI I am a new Linux user.

I just updated with zypper dup, restarted and am unable to login to the GUI. I have created a backup user, logged in, cp’ed my home/user file to the backup_user, so as to save my original /user files. This is the second time after an update-restart that I am unable to login. Any idea what could be going on?

Thanks!
Brian

Why do you use ‘dup’ on Leap? It might even cause your issues. Leap needs ‘zypper up’. Can you boot the previous kernel of snapshot from the Advanced options in the boot menu? What is the videocard involved ?

Hi,

Looks like I should’ve used zypper update. ****it! I tried booting from the previous linux version from the advanced options boot menu (is this what you suggested?).

Video card:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] [1002:68f9]
Subsystem: Dell Radeon HD 6350 [1028:2126]
Kernel driver in use: radeon
Kernel modules: radeon

Thanks for the reply!

Cheers,
Brian

What exactly does “unable to login” mean? Do you enter username and password but fail anyway? Is the login screen black? Is keyboard input ignored?

When you installed, which did you choose, Gnome, KDE, or one of the others? Such choice would affect which login manager was installed.

zypper se -si dm

will list installed dm package gdm, kdm, lightdm, lxdm or sddm plus xdm, and

ps -A | grep dm

will show which, if any, is running.

I have AMD/ATI Cedar in two openSUSE systems and have no such trouble as you describe.

This has happened also to me occasionally in the past, more rarely since I use leap, but indeed again yesterday. I am using leap with the latest QT and plasma repositories. After a “zypper dup”, much of plasma was updated and after the reboot no gui came up anymore.

I disabled the QT and plasma repositories from the command line, ran another “zypper dup” which downgraded plasma to some much earlier version, and the gui was back again.

On using “dup”, recent kernels and recent QT/plasma upgrades, I realize that maybe I should switch to tumbleweed indeed. I just cannot guess HOW unstable that system might turn out to be…

If you choose to “update” with the “upgrade” procedure “zypper dup” then, you are well advised to follow the rules documented here: <https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha.update.osuse.html&gt; and here: <https://en.opensuse.org/SDB:System_upgrade&gt;.
And, when you’ve followed all the steps documented in “the rules” you should run “rcrpmconfigcheck” with the user ‘root’ to make sure that all the changes in the configuration files have been worked through to ensure that the “new” configuration is correct for the newly upgraded system.
[HR][/HR]Be all that as it may, as a new user, you should be following the advice in the openSUSE documentation:
<https://doc.opensuse.org/&gt;; Start-Up Guide: <https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/index.html&gt;;
YaST Online Update: <https://doc.opensuse.org/documentation/leap/startup/html/book.opensuse.startup/cha.onlineupdate.you.html&gt;.
[HR][/HR]Actually, as a new user, you should simply be using the updater applets within the GUIs:

  • KDE Plasmoid “Updates”;
  • GNOME: “updater applet”.