Cannot login to gmail chat with KTP

I hope this question has not already been answered. I searched for similar topics but did not find anything.

I’ve been using Leap with Plasma since it came out, and I have never been able to use KDE Telepathy (ktp) with my gmail account. The same account worked just fine with KTP 0.8 (KDE4-based) in 13.2 (and using the 13.2 packages in Leap), and it still works perfectly with Kopete. I don’t know what I am doing wrong.

I am creating my KTP account as a Jabber account using the Online Accounts KCM. It seems to work without a problem, but once I try to enable it, my credentials are always rejected (I get a notification saying so). I have tried copying all the informations I could from Kopete’s configuration (server address etc.), since that one works, but it doesn’t change anything. It seems to me that KTP doesn’t actually use the provided password since the field is always empty even though I always check “Remember password”. My installation of KWallet5 is functional so I don’t think this is the issue.

I have installed KTP through the pattern telepathy-kde.

I have the same problem with my other machine running Tumbleweed.

Any advice?

I forgot to look on it seems I am not alone:

Have the exact same problem.
I mostly given up, but will post to the kde bugs too.
By the way, it seems like my one tries to use gnome-keyring for some weird reson, it asked me to set up a new “default keyring”, and after that, gnome-keyring demon is running. >:( What the hell? I installed/running the plasma telepathy pattern…