Cannot login, keyboard not responding

As the title reads out, i upgraded suse 11.1 to 11.2, but the keyboard is not responding… At the login screen! If i write in the console output at boot, it writes, and also if i want to login under console. But the “graphic form” won’t let the keyboard write. I simply cannot login!

Tech. data: Upgraded from DVD, 11.1 -> 11.2, first tried with zypper, but it failed and wanted to download 1Gb again.
PC: Acer aspire one ZG5
Keyboard worked before: Of course!

Any prompt response will be apreciated!

PS: Sorry for the typos this may have.

EDIT: I tried with an USB keyboard, but it also won’t do. Curiously, both write in console.

Can you confirm if your graphic form as you said has a window decoration or none? meaning you can see the maximize, minimize buttons. What are you using?, kde, gnome or xfce?

Well, since the keyboard doesn’t work in the login form, i can’t get to my graphic desktop. :stuck_out_tongue: I’m using KDE.

Sorry I mistaken the graphic form as the gui.:stuck_out_tongue:

How can i start the graphic server from console? I can login from there.

So I take it that your keyboard works in cosole ok? Maybe you can configure your keyboard from yast (ncurses console version)?

Yup, it works on console, even chars like the the Ñ and so. I tried writting “yast” and i got some rudimentary forms, that don’t display well, but can show.

Let me know if there are some fancy processes that i can try for fixing this - i’ve been unable to login to my desktop, and i certainly can take black scary screens on.

Maybe try with an external keyboard plugged in, if you have one available. The output of dmesg might be useful in the diagnosis.

I had the same problem with an Asus Eee PC 1000H after performing a live upgrade from 11.1. I could solve it by upgrading the HAL from the Factory repository:
After rebooting I could use keyboard/mouse in runlevel 5 again.