Cannot login KDE GUI, F3 console works OK

Just finished 13.1 KDE DVD upgrade. On reboot I get the normal GUI screen and login prompt:
Welcome to ‘computername’
Full username
Login Name
password prompt

After entering my pw, the login process starts with the screen drawing the box which ordinarily shows the objects as the desktop loads (the image of a hard-drive, tools, globe, desktop, KDE logo). As the object of the hard drive is appearing I am returned to the login prompt screen. The pw must be correct because if I enter a wrong pw the screen prompts with bad pw and does not attempt to display the 4 objects which normally display when KDE is starting.

I can logon as a user or as root in a terminal session (ctrl-alt-F3).

in the GUI, logging in as root gives me a purple terminal window in the upper left of the screen. it does not attempt to start KDE.

Finally, I should mention that this upgrade is from v12.2.

What may be causing this odd behavior, something wrong with KDE upgrade I guess?

Jon

Probably.
Btw. you can choose the session you want to start (KDE, GNOME, TWM, IceWM, …) if you click on the “wrench” symbol on the login screen.

Have a look at the file ~/.xsession-errors (if that’s empty, take ~/.xsession-errors-:0 ), that should provide a clue.
Maybe upload the file to SUSE Paste and post a link.

My first guess: You’re missing /usr/bin/krandrstartup. Try to reinstall the package kscreen.

sudo zypper in -f kscreen

Also interesting would be, what graphics card you have and what driver you use (i.e. did you install a proprietary one?)

What video card and driver?

It could be a bad config in the ~/.kde4 folder

You may try a different (new) user.

You can add auser by loging into terminal as root and then run yast from the command line and adding a test user

Then init 5 should start the GUI login and you should try logging in as the new user. Note the user may not be in the login windows list just enter the name and password

Wolfie323:
Thx, I’ll try kscreen and post results.

GoGalThorp:
I already tried creating user but in yast2 (hmmm, is it yast and not yast2?) the fields will not take keyboard input, but mouse works. I tried adding group kdm & users to myself but no luck.

I haven’t researched user creation via cmdline. Guess I’ll look into that.

I’ve tried the different deskop configs and they either respond the same or don’t work at all.

Video card is AMD Radeon HD7570. Prior to upgrade I was using fglrx created w/ atiupdate but I assume 13.1 upgrade over-wrote that. Perhaps not. And that video card is working fine in USB Live boot of 13.1 And I find a fglrx-build.log so it was rebuilt, I still need to examine it.

I wanted to try to boot with nomodeset but I can’t get the boot options line to show. I thought F3 or space toggled it but no luck there.

I vey much appreciate your quick replies to my original post.

Jon

When logged in at a terminal session, edit the file “.kde4/share/config/kwinrc”


[Compositing]
Enabled=false

That’s a segment of the file here. Add that line “Enabled=false” in the “Compositing” section.

Then try again. What that does is disable desktop effects for KDE. They appear to not be working for you. They don’t work on a box I have with radeon graphics.

I don’t know how to mount a usb stick in terminal so I can’t figure out how to get the xsession-errors off the computer to upload it. And booted to Live I don’t have permissions to do anything with it. I’ll try going back to my failed 13.1 KDE and seeing what I can do with chmod.

kscreen did not change anything.

If I can get the log off that computer I’ll upload it.

thanks, Jon

BINGO! That worked. Thanks, nrickert. I changed kwinrc for both root & User. I haven’t had time to play with it other than drag a window and notice it is very slow at re-writing the screen. It’s as if my x64 is a now a 286 in terms of screen draws. But at least I’ve got my desktop back.

I’m wondering if I should still post the .xsession-error log that was previously requested.

And KDE on v12.2 was much better on the display response. I do have an onboard Intel graphics (I forget which one, it’s currently disabled in the bios) that outputs VGA (vs DVI for the Radeon). I can try that but I am also wondering if I should dump just the Radeon (it came with the Dell) and get something else. If so, I would like suggestions.

Thanks, Jon

I spoke too soon on the ‘it works’ part. Yes, I can now login to KDE but none-KDE apps don’t work.
I can open, for instance, dolphin & kwrite.
But FF and Tbird take me to the login screen.

I tried running Tbird from terminal but /bin/sh thunderbird.sh fails with “no such file” when run from the directory it lives in.
I tried a reinstall of FF from Yast2 and that didn’t work, I even think that maybe YaST failed before it finished, but I was looking away.

A number of other apps that I am still investigating.

So I must have more than a video card problem.

Jon

This is a link to my .xsession-error-:0
SUSE Paste

My graphics card is Radeon HD7570.

Even though I have got KDE logging me in now that I’ve modified kwinrc I still have plenty of problems (for example FF & Tbird won’t run but I am online w/ Konqueror) and any suggestions appreciated.

Rgds, Jon

Well, this indeed seems to be a graphics driver problem then.

Install the proprietary fglrx driver:
openSUSE Lizards

Wolfie:

The beta driver at Lizards solved many problems I was having, I still need to carefully read the logs and check some more apps.
For anyone with Radeon cards the above link should be checked out.

Thanks, Jon

Although you describe different problems than what I experienced, since you did approx. what I did (migrate an existing openSUSE to new hardware with an entirely different family GPU), I suggest you also do what solved my problem
http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/492257-system-migration-how-uninstall-blacklist-old-firmware-nvidia-gpu.html#post2599505

What happens is that at least for the GPU, openSUSE may specify the hardware display and then unless changed will always attempt to load the drivers for that display. Comment out everything in the file which allow openSUSE to choose the driver based on detected hardware.

HTH,
TSU

nrickert:

After installing the beta flgrx for radeon I went back to kwinrc and removed the comment you suggested. So far all is well.

Rgds, Jon

Great.

If you had turned on desktop effects in your desktop settings, that would have removed the line (or perhaps changed the “false” to “true”). You only need to edit the file when things are so messed up that you cannot get to the desktop configuration settings.

I had exactly the same problem. It is not the graphics card that was at issue, but from tmpfs filesystems. I was created tmpfs with zero lenth. I recreated the fs with the a 50% sise as those created automatically created during installation and everything is back to normal.

Hope this help

Are the tmpfs partitions listed in your /etc/fstab?

If so remove them they are created automagically now