cannot login - failure to start network manager / login service

Hi all- Linux newbie, sorry. Help & patience appreciated.

I can no longer get to the desktop (GNOME) of my Leap 15.2 system. There are several messages of “Failed to start Network Manager” followed by a loop of “Failed to start Login Service”.

I recently attempted to update all packages using zypper. The YaST GUI updater kept getting stuck on one (of ~500) updates with a dependency conflict.

zypper aborted since root was full. That was caused by a corrupt database (plexmediaserver). I Deleted the db files and rebooted

Here are the last steps taken:

  1. Attempted to update packages using YaST GUI updater - failed due to a compatibility conflict
  2. Attempted to update using zypper ref followed by zypper update
  3. zypper aborted: root part full
  4. deleted plexmediaserver’s corrupt / excessively large db files to free space
  5. reboot → login failure

I assume this must be down to zypper installing some updates (but not all).

I’ve tried all 4 kernel options in GRUB to no avail.

Do I:

  • get to a shell and try to roll back / repair the updates? How?
  • try to locate the install media (doubtful) to go back to that kernel?
  • … something else entirely?

Many thanks!

OK, phew: I was able to use one of the “read-only snapshots” to get it to boot & login successfully. I chose one of the snapshots not marked zypper at the end (pkgkit, maybe? really should have written that down).

Per the docs, if everything with this snapshot checks out, I would just need to run

sudo snapper rollback

from the active snapshot to revert the “default” state back?

And if I understand correctly, data is preserved; will this affect e.g. the state of MariaDB databases?

I would advice to upgrade to 15.3 asap. It will become more and more difficult to get software for 15.2 and no updates for the OSS and non-Oss pacakages are offered anymore (since the begin of this month January).

Thanks Henk, will do. Given experience with zypper I think I’ll try the offline upgrade after attempting a rollback to stabilize things. Not that this was in any way the package manager’s fault.
The offline upgrade docs reference 42.1 but assume the process is largely the same for Leap.

And answering my own question: no, things like databases, user data etc. are not affected b/c snapper excludes them by default. Good thing it was designed by smart people to help people like me :slight_smile:

And this:

Check that you will get after the zypper dup and a zypper up, two more repos. When not come back here (or find relevant threads here).

Just reporting back. The snapper rollback worked perfectly :cool:

The initial upgrade attempt (from USB/iso) got stuck on a black screen, did not catch what the last successful load was.

But tried it again last night and it completed successfully. I did have it connect to configured repos and it updated a bunch of media-related codecs (gstreamer etc.).

Interestingly in the upgrade setup it was much easier to tell it how to resolve conflicts vs. the YaST updater. YaST kept telling me “there’s a conflict” but the only option seemed to be to skip that update (after finding it in a long list of package updates). I probably missed how to do that properly with the YaST GUI updater.

I did not yet run zypper dup or zypper up but the GNOME updater says all is up to date. Should I?

Thanks for everyone’s help!

Good action. :shake:

Did you check for the extra repos as I mentioned above?

And doing a zypper up now is the best way to check if there are updates. Use the desktop update icon only as a “maybe I should check” indication. i have removed it in my KDE (in fact from the system).

Errr… not sure :|. Are they #13 & 14 below? (Sorry - I couldn’t figure out how to attach .txt / make the formatting better)

From zypper repos:

#  | Alias                       | Name                                                                 | Enabled | GPG Check | Refresh | URI
 1 | openSUSE-Leap-15.3-2        | openSUSE-Leap-15.3-2                                                 | No      | ----      | ----    | hd:/?device=/dev/disk/by-id/usb-Generic_Flash_Disk_CDA5FE7A-0:0-part2
 2 | repo-backports-debug-update | Update repository of openSUSE Backports (Debug)                      | No      | ----      | ----    |
 3 | repo-backports-update       | Update repository of openSUSE Backports                              | Yes     | (r ) Yes  | Yes     |
 4 | repo-debug                  | Debug Repository                                                     | No      | ----      | ----    |
 5 | repo-debug-non-oss          | Debug Repository (Non-OSS)                                           | No      | ----      | ----    |
 6 | repo-debug-update           | Update Repository (Debug)                                            | No      | ----      | ----    |
 7 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS)                                   | No      | ----      | ----    |
 8 | repo-non-oss                | Non-OSS Repository                                                   | Yes     | (r ) Yes  | Yes     |
 9 | repo-oss                    | Main Repository                                                      | Yes     | (r ) Yes  | Yes     |
10 | repo-sle-debug-update       | Update repository with updates from SUSE Linux Enterprise 15 (Debug) | No      | ----      | ----    |
11 | repo-sle-update             | Update repository with updates from SUSE Linux Enterprise 15         | Yes     | (r ) Yes  | Yes     |
12 | repo-source                 | Source Repository                                                    | No      | ----      | ----    |
13 | repo-update                 | Main Update Repository                                               | Yes     | (r ) Yes  | Yes     |
14 | repo-update-non-oss         | Update Repository (Non-Oss)                                          | Yes     | (r ) Yes  | Yes     |

They are #3 and #11 in your list. All looks well there.

Excellent - thanks again!

I ran zypper ref and zypper up and looks like all is up to date. So satisfying :smiley: