Cannot login after partition resizing

Recently i was forced to increase my root partition size by shrinking the home partition (there was not enough space to install the current update)
I used Gpated from UBCD. The operation finished without errors. But after rebooting the system i wasn’t able to login (after entering the password the screen goes dark for a few seconds and then goes back to login screen)

When i logged in in text mode and tried to start x i got the following output:
https://s32.postimg.org/5pe4ogrqt/PHOTO_20160719_154615.jpg
After googling i have found few solutions like removing the Xauthority file (did not help) and reinstalling nvidia drivers (my graphics card is ATI radeon HD 4850)

I assume the partition resizing messed up my system, but i have no idea how to fix this, so any help would be much appreciated.
What additional info can i provide?

Probably the UUID has changed on the partition you moved

Assuming you have a rescue disk check UUID of the partition and if different from that in /etc/fstab on the main drive fix it

Also I’m not sure size reduction is FS XFS

Based on your pic,

It looks to me that your root partition is found, but your home partition cannot be found.

As goglathorp suggests, <that> specific entry in your fstab is now probably incorrect (It’s likely that you did more than simply re-size… It’s probably re-located or re-created as well).

In the future, if you make changes to your <root> and home partitions, I highly recommend using gparted live (the LiveCD version of gparted) instead of using an installed version of gparted so that changes can be tested and executed immediately without a reboot. To me, applying changes immediately without a reboot is less complicated and less prone to error.

I still use gparted for modifiying non-root data partitions.

Also, you <may> be able to recover quickly using the DVD as a rescue disk…

TSU

I forgot to mention, i have checked the fstab entries right after the partitioning operations ended, the home UUID wasn’t changed (later i tried to mess up the home UUID intentionally and got completely different error with the system entering emergency mode.

The home and root partitions are accessible and readable from the liveCD

After every login atempt an xsession errors file is generated in my home directory, but it’s empty.
Creating new user does not help
Using iceWM (as suggested on many forums) and any other session options like gnome and XFCE also didn’t help

So basically i’m stuck with a “cannot login” issue and i have no idea how to fix or even diagnose it. Hopefully there is a way to fix it without reinstillation.

In the login screen, hit Ctrl-Alt-F2
Login as root ( in this occasion there’s no other way ) and do

yast

now use the arrow keys and the tab key to navigate. Go System - Partitioner. Check whether /home is the mountpoint for the partition your homedirs are on. The partitioner might complain about your fstab

Errr, can you show output from


ls -l /home/*

I have checked the home mountpoint with yast and it was OK
Here is the output from
ls -l /home/*
http://pastebin.com/DpBJeJc6

**Update.
**I found out that i actually can login into graphical session via KDM and iceWM but only as root, login as any other user (new or old) fails.

Is this a permission related issue?

Did you copy over from an NTFS-formatted partition? Looks like there’s some Windows stuff in there
Please also show


ls -ld /home/roman

I have several NTFS partitions and this is possible i have moved files to linux partitions and backwards.

ls -ld /home/roman outputs the following:

drwxr-xr-x 97 roman users 12288 Jul 27 15:09 /home/roman

not sure what the output means, but it’s clearly different from my other two opensuse PCs outputs

drwxr-xr-x 49 roman users 4096 Jul 27 01:13 /home/roman
drwxr-xr-x 74 roman users 4096 Jul 27 16:22 /home/roman

Does the output say something about the issue?

Output of

mount | grep home

please,

It looks like users don’t have write permissions on /home

mount | grep home gives

/dev/sda7 on /home type ext4 (rw,relatime,data=ordered)

Update: i have tried to launch gnome session, like the others it works only for root, and as soon as i logged in i was greeted with a warning message from disk manager utility " the volume home has 0 bytes free space"

dolphin also shows 0 bytes free. I cannot copy a file on the volume, but i’m sure there is something abot 80 Gb free.

You can doublecheck, the following displays free space for every mounted partition (plus more)

df -H

Maybe your partition is damaged, maype it’s otherwise faulty but can be fixed, maybe something else…

TSU

Well it looks like it, because df -H Shows:

Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        3.0G     0  3.0G   0% /dev
tmpfs           3.0G  4.1k  3.0G   1% /dev/shm
tmpfs           3.0G  2.4M  3.0G   1% /run
tmpfs           3.0G     0  3.0G   0% /sys/fs/cgroup
/dev/sda5        55G   33G   21G  63% /
/dev/sda7       1.9T  1.8T     0 100% /home

pretty obvious, 0 free space. but if delete some files i get the same amount of space freed, so i assume the partition was damaged in the partitioning process (the system does not “see” the free space)