Cannot log in after kernel update

I installed the new security update earlier today. Now, the login screen no longer responds to my keyboard. In particular, I cannot type my password to log in. If I reboot into failsafe mode, the keyboard works and I can log in. What might be wrong, and how might I fix this? Thanks for your help!

I’m running 11.3 on a white MacBook 4,1.

i had problems with the latest update as well. i did the following command as root

zypper in --force kernel-desktop=2.6.34

it had a warning about the kerenl 2.6.34-12 being older than the current one and i had to confirm. then it had a warning about a dependency that would have to be downgraded as well. i chose the first option which was to downgrade the dependency as well. rebooted, and was back at the rpevious kernel.

Thank you briandial for letting annoyingpi know how you restored your old kernel due to the problems you also had with the new kernel update.

Thank You,

So I wasn’t having trouble logging in, but my computer would freeze if I tried to enable the desktop effects, so I tried to downgrade to the previous kernel.

After I downgraded to the previous kernel, my computer froze again when I tried to enable the desktop effects. And when I tried to start it up it had a kernel panic, now I’m booting up on a different partition. I can’t even use failsafe mode.

Is there anyone that can help me with this situation?

Thanks! That was precisely what I needed. One more minor question: How do I set the 2.6.34-12 kernel to be the default at the startup menu? The updated kernel is currently still the default, and I don’t want to have to manually select 2.6.34-12 every time I boot.

The workaround I posted here worked for me on 2 machines (one of them is an iMac) and I’m hoping to use it on some others: Keyboard & mouse freezes
No need to downgrade the kernel (I first did that too). If you have an ATI and you are using radeonhd, just make sure you still have ‘nomodeset’ in the kernel options in your /boot/grub/menu.lst. Otherwise X won’t start.

  1. You can edit the /boot/grub/menu.lst file as root and set which option you want to default to.
  2. You can set it in Yast
  3. You can use Yast to remove the newer kernel.

Forgive me my ignorance.
Are you able to boot to the command line for that machine?

Since your freeze problem appears related to desktop effects, would you consider restoring your original kernel?
zypper in --force kernel-desktop=2.6.xx ?

After a successful restoration of the kernel, validation of logins, then work on why desktop effect freezes your machine.

Almost forgot, any significant error messages in /var/log/messages or /var/log/warn concerning the failed logins or desktop effect freezes?
You might need to look into /var/log/messages..bz2 and /var/log/warn..bz2