cannot load SUSE after reboot.

First off, im a linux noob and this is my first linux OS.

I have a ThinkPad T22 (from some google searches might be a problem as it is). I am installing SUSE on the whole drive, ie no dual boot.

I can install SUSE with no problem. I can run everything with no problem after the install. I restart the computer once and i get “Error loading Operating System” on a boot. After that, I cannot get back into SUSE. I tried the repair option once and it did show some boot loading problems but it was able to repair it. Restart… same problem

I tried searching in the forums and i am not really sure how to continue. I have reinstalled SUSE twice same things happens. I did see the item for Thinkpad Lenovo PC’s but i am in the process of trying that but since i have reinstalled and wipe the drive many time im not sure if there will backup of the MBR. (shot in the dark)

If you need more info please let me know. Any help will be greatly appreciated.

Did you choose not to use a boot loader, thinking it’s not needed because there’s no other OS on the drive ? If you did install GRUB:
Boot from DVD, choose Install, continue until you get the option ‘Boot installed system’. openSUSE will look for an install and boot it. Once booted, go to console (Ctrl-Alt-F1) and login as root. At the prompt type “mount”. This will show you where your root-partition is: /dev/sdaX, where X is a number. Next type 'grub-install /dev/sdaX, where X is the number found before. Reboot, and it should work now.

Wrong, a bootloader is needed, no matter how many OSes are installed (at least if $NUMBER_OF_OSes > 0 :-))

That work beautifully. Thank you for the easy steps. The only thing i should mention was that i couldnt boot off the DVD for SUSE 11.1. It just wanted to reinstall but i found that Super Grub Disk on the forum that booted the SUSE so at least i could get into it.

Somehow i must have told it that i dont need a bootloader somehow…

Thank you again.