Cannot load library /usr/lib/kde4/, which multimedia interface with

sound cand can replace it?

after the last problem and i have kept using kde 4.6 without a problem till the upgrage that make the phonon do problems again.

i have used kde 4.6 and i used “zypper dup” without changing the repository at all.
after one of the times i have used “zypper dup” the phonon started to make[FONT=Verdana] problems[/FONT] again and since then i have a sound problem.
i don’t have sound in the kde and gnome now.
i tried “zypper dup” to upgrade to kde 4.7 and then to kde 4.8 and the problem of the phonon still continue.

if i configure the sound card from zero i do have sound but only one program and any other new program that using the sound taking control on the sound and some programes don’t sound at all.

the phonon is connected to other programs so i want to used a different multimedia interface with sound cand with the kde and gnome. how do i that?

I might suggest you open up the “My Computer” icon on your desktop and post a copy of that here to see as well. It would tell us a lot more about your present openSUSE configuration.

Thank You,

opensuse 11.4,64bit
kde 4.8 upgraded today with “zypper dup”

kde-open -v
Qt: 4.8.2
KDE Development Platform: 4.8.4 (4.8.4) "release 513"
KIO Client: 2.0

zypper lr
#  | Alias                                              | Name                                               | Enabled | Refresh                                                    
 1 | Apache                                             | Apache                                             | Yes     | Yes                                                        
 2 | Apache_PHP_modules                                 | Apache PHP modules                                 | Yes     | Yes                                                        
 3 | Apache_modules                                     | Apache modules                                     | Yes     | Yes                                                        
 4 | Contrib                                            | Contrib                                            | No     | No                                                        
 5 | JAVA                                               | JAVA                                               | No      | No                                                         
 6 | KDE:Extra                                          | KDE:Extra                                          | Yes     | Yes                                                        
 7 | KDE:Release:46                                     | KDE:Release:48                                     | Yes     | Yes                                                        
 8 | LibreOffice_STABLE_                                | LibreOffice STABLE                                 | Yes     | Yes                                                        
 9 | Src-non-oss_                                       | Src-non-oss                                        | Yes     | Yes                                                        
10 | Updates-for-openSUSE-11.4-11.4-0                   | Updates for openSUSE 11.4 11.4-0                   | Yes     | Yes                                                        
11 | Wine                                               | Wine                                               | Yes     | Yes                                                        
12 | ati_11.4                                           | ati 11.4                                           | Yes     | Yes                                                        
13 | driver_wireless                                    | driver_wireless                                    | Yes     | Yes                                                        
14 | games                                              | games                                              | Yes     | Yes                                                        
15 | google-chrome                                      | google-chrome                                      | Yes     | Yes                                                        
16 | google-earth                                       | google-earth                                       | Yes     | Yes                                                        
17 | mozilla                                            | mozilla                                            | Yes     | Yes                                                        
18 | multimedia:apps                                    | multimedia:apps                                    | Yes     | Yes                                                        
19 | multimedia:libs                                    | multimedia:libs                                    | Yes     | Yes                                                        
20 | nvidia_11.4                                        | nvidia 11.4                                        | Yes     | Yes                                                        
21 | openSUSE-11.4-11.4-0                               | openSUSE-11.4-11.4-0                               | Yes     | No     
22 | packman-essentials                                 | packman-essentials                                 | Yes     | Yes    
23 | packman-multimedia                                 | packman-multimedia                                 | Yes     | Yes    
24 | packman_ | packman | Yes     | Yes    
25 | repo-debug                                         | openSUSE-11.4-Debug                                | No      | Yes    
26 | repo-debug-update                                  | openSUSE-11.4-Update-Debug                         | No      | Yes    
27 | repo-non-oss                                       | openSUSE-11.4-Non-Oss                              | Yes     | Yes    
28 | repo-oss                                           | openSUSE-11.4-Oss                                  | Yes     | Yes    
29 | repo-source                                        | openSUSE-11.4-Source                               | No      | Yes   

i tried change the name of the file “” to “” and reinstall the alsa with the rest of the sound system,but it fail to recreated the file from zero.

i have no idea how to replace phonon with a different multimedia interface with sound card or fixing it

i have returned the file “” to his original name and and still i have no sound.
the only mode and program i have sound now is “yast->sound configuration” only without change the configuration.

i tried to edit the last message,but the system won’t gave me.

I highly recommend you read through the following write up:

You are keeping way too many repositories and zypper dup might not do what you had hoped. For instance, lets look at just upgrading to KDE 4.8 where I suggest you use the repository view in YaST and then elect to switch to that repository. I normally suggest using **zypper dup **to switch to a newer version of openSUSE, with only openSUSE specific repositories being enabled. I can also say I have not tried specifically to upgrade KDE to 4.8 in openSUSE 11.4 and I am not sure of that outcome. I presently use openSUSE 12.1 and have only 13 repositories installed and 10 are enabled, a number higher than even I like to see. You have 29 repositories installed and 24 are enabled. So, I would pair down repositories before I did anything else. For instance, you need only one Packman repository installed called All of Packman. Use the Repository view in YaST Software Management to see what you have installed, if anything, from each of the added repositories you have installed. And read through the document I have pointed you to.

Thank You,

i saw now after reading your message that i have triple packman and double multimedia and i will fix that now, thanks.:slight_smile:

the problem started with kde 4.6 after an upgrade as i do every week with “zypper dup”.
i wrote only after the problem started in kde 4.6 upgraded to the new version of kde 4.6,only then i have upgraded to 4.7 (i had no problems doing so) and then to 4.8 and that it, no problem with upgrading from 4.7 to 4.8 as well.
may only problem right now is the phonon because of some kind of a problem the upgrade to the new version of 4.6 created. the last stable version was kde 4.6.2 i thinks,but not sure.

You are doing to much *zypper dup *IMHO. That is only for a real upgrade action. Not for day to day updating.

On 2012-07-09 05:56, opsystem wrote:

> the problem started with kde 4.6 after an upgrade as i do every week
> with “zypper dup”.

You like living dangerously.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

a,how can i fix the phonon???
it’s still the some error link.

b,what is so wrong with using “zypper dup” as long i don’t change the repositories list and all the repositories belong to suse,kde,gnome,ati,nvidia,mozilla,packman,wine.
the site of suse said using “zypper dup” to updating old packages as you can see here:
SDB:Vendor change update - openSUSE
and i don’t know any other way to updating my old packages.

Because* zypper dup does what that link tells you, it changes Vendors. Every time back and forward depending what the level numbering might be. And most people want to use e.g. certain packages from Packman, always, disregarding the version. Thus they do zypper up *to get the updated versions from the Vendor they choose.

ok i will check that next time i want to updating old packages,but now how do i fix the phonon or switch to something else?
i don’t have any sound right now as i wrote beside the “yast”->“sound configuration”