Cannot Link using mpicc

I recently upgraded from opensuse 11.0 to 11.3. I had LAM installed with 11.0, and all was well. I’m trying to install it again under 11.3.

I have installed lam-devel (and openmpi-devel), as well as gcc. When I try to compile and link using mpicc, everything compiles, but I then get the errors

gcc: libtool:: No such file or directory
gcc: link:: No such file or directory
mpicc: No such file or directory

Typing whereis for each of these gives

> whereis libtool
libtool: /usr/bin/libtool /usr/bin/X11/libtool /usr/share/libtool
> whereis link
link: /usr/bin/link /usr/bin/X11/link /usr/include/link.h /usr/share/man/man1/link.1.gz
> whereis mpicc
mpicc: /usr/bin/mpicc /usr/bin/X11/mpicc /usr/share/man/man1/mpicc.1.gz

What gives? Is there something more I need from the repositories? I can compile and link serial programs using gcc just fine.

Are you trying to install as root? Only the install step should be done as root.

I installed everything through the repos, since they’re all available. My attempts to compile and link are done as a regular user.

What is your path? at terminal

/usr/bin should be in there

Also maybe show us the actual commands being used in addition to the output.

Ok, I don’t know what happened, but I tried to compile with mpicc this morning, and it seems to work perfectly. I had tried rebooting yesterday, but to no avail.

You are correct that /usr/bin shows up in my PATH. Yesterday, I couldn’t even get

mpicc test.c

to link anything. Maybe I just need a beer.

Thank you anyway gogalthorp.