Cannot install Tumbleweed due to boot/grub2-failure


I am currently trying to install Tumbleweed on my Surface Pro 3 and after managing to finally get a good copy of an .iso-File onto my USB-Stick I cannot complete the installation due to a failure at the bootloader configuration. The installation aborts and delivers the following message:

Execution of command “”/usr/sbin/shim-install", “–config-file=/boot/grub2/grub.cfg”]]" failed.
Exit code: 5
Error output: Installing x86_64-efi platform.

Before that a problem already occured at the bootup: Secure Boot Violation → Invalid signature detected

I could hit ok but then the mentioned error at the bootloader configuration occured.

Since I checked the .sha256-signature of my .iso I was sure that there was no problem and I disabled Secure Boot and proceeded accordingly to this thread: “

Nevertheless the error at the bootloader configuration occured. I wiped my USB-Stick clean and partitioned it with GPT in Rufus. With ImageUSB I put the .iso back onto it but the error is still there.

I should mention that I just recently switched to Linux and installed Ubuntu before openSUSE but didn’t quite like it. Until now I am not really accustom to the Linux universe but I am ready to learn. I have another computer at hand with Windows running to investigate the problem and make the changes to the USB-Stick as well.

Thanks in advance for your help!

UPDATE: Secure Boot Violation does no longer occure even with Secure Boot enabled, but the grub2-error is still there

Hi and welcome to the forums and to Linux!

I think I have read somewhere, that secure boot can cause shim to fail. Go to the BIOS and disable it there, to see if the issue persists. I would imagine, that this will fix your issue.

If that does not do any good, have you made sure the installation media is fine? The installer should give you an option to check it and if you are in doubt, you can re-download it to give it a try.

Hey! Thanks for your answer :slight_smile:

Unfortunately disabling the Bootloader didn’t help. I still get the same error.

Now I tried to “Check Installation Media” and after the green Bars I get one single line saying *** signal 11 ***
After two Minutes the system restarts.

I guess that means, that my file is broken…
My Problem is that I am currently living in a remote area abroad and downloading big files, means staying up all night to use the nevertheless small bandwidth. I had to ty it already a couple of times to get an .iso onto my USB-Stick.
Do I really have to download it one more time? What can I do to avoid bad files?


I am living in Venezuela and over here the internet is pretty slow.

One thing you can do, is to use the torrent download to download the image. This way you don’t have to sit all night and watch it, so it doesn’t fail and chances are way better in your case, to get a working image.

You might also want to check here:


Unfortunately other than this, I cannot tell you much more. I am using Leap 42.2 and while I have been working and playing around with Tumbleweed at times, I have never spent the time investigating it well, nor did I have that error.

have you ever had linux running on this laptop?
if the signature check is ok I would exhast other possibilities before redownloading.
disable options related to windows fast boot
disable CPU-cache in the BIOS if you have this
If i remember you can simply use dd to write the iso to disk, if so this might be the most trustworthy method
arch wiki always useful but beware following distro specific steps:

Thanks for your input but unfortunately it did not help me getting to a solution.

To answer your questions:
*yes, Ubuntu LTS 16.04 with the patched Tigerite kernel but I didn’t like Unity and that multitouch didn’t work both on touchpad and touchscreen and the left-click on the stylus wasn’t supported
*before I installed Ubuntu LTS 16.04 I made sure to disable fast startup in Windows 10 but I am not quite sure if that changed with the installation of Ubuntu and since I cannot boot it anymore after the first try of installing openSUSE I’m afraid I cannot change anything anymore
*since the Surface Pro 3 boots in UEFI mode I guess I cannot change anything in BIOS
*I knew that link but since I am new to Linux I do not understand the not-really-beginner-friendly archwiki and hoped to get around this by trying openSUSE after I found this: which sounded promising even though not beginner-friendly.
I thought that I could at least manage the installation before getting to the first difficulties when configuring the kernel and drivers but …

I tried it several more times to write the .iso onto my USB drive with different approaches and by now I am quite sure, that the file isn’t bad. I also tried to format all the partitions on my hard drive during the installation but after that the error still appears. What’s somehow strange is that the error didn’t occur when I disabled secure boot support during the installation process. The installation finished and the system rebooted, but it simply opened up the installer again and when I tried to boot from the hard drive I landed in grub so it seems as if the installation never took place :question:

Since I need my computer up and working by tomorrow morning I will reinstall Ubuntu which I had running before or give Fedora a shot since it should be easy to install ( and will install GNOME. Maybe it was just Unity that I could not get accustom to.

Nevertheless if someone with deeper knowledge of Tumbleweed had a proper answer for me I would give it another shot. Maybe first as a dual boot to make sure I still have at least something to work on. I would really like to explore the possibilities of openSUSE and am a little bit disappointed that I couldn’t even make it past the installer :disapointed:

UPDATE: I couldn’t leave it at that and tried it again overnight…and found a solution :slight_smile:

I managed to boot from the Live USB and saw that the efi-files were missing in the boot directory of my hard drive. I tried copying them from the default locations of the Live USB but of course I couldn’t use the grub.cfg file there. I therefore copied the default file of the root partition. After that I tried to automatically update grub over

**grub2-mkconfig -o /boot/grub2/grub.cfg**


**grub2-install /dev/sda**

which resulted in an error output with something called “fstab”.

As mentioned earlier I am new to Linux and would rather call it experimenting than knowing what to do rotfl!

I found fstab in the /etc and saw that apart from auto-mount settings nothing was configured. Which probably means, that the installation didn’t mount my partitions successfully. I reinstalled and experienced the same.

I used a Boot Repair Live USB that I had created earlier, because I wanted to know if grub2 was broken and wiped my hard drive clean. I reinstalled openSUSE, left Secure Boot on and configured my partitions in expert mode. The error occured again…

However the installation finished this time and I was able to boot Tumbleweed from my hard drive successfully for the first time with Secure Boot still enabled.
I think I now have a working OS which still needs to be tweaked but thus far I am happy with the result.

Thanks for your help! :wink:

I am wondering if what I experienced was a bug in openSUSE. At least it looks similar to this one: