Cannot install suse on laptop

I have a Sony Vaio laptop. I try to install suse 11.1 doesnot let me. In the third step in the installation, when it detects the cd-rom I get an error message:

"Unable to mount cd-rom installation. This probably means that the cd-rom was not in the reader. If so, you can insert it and try again.
Trying to mount the cd-rom again? "

I tried it with Windows, Ubuntu and MEPIS and I have no problems, but suse seems to be having problems with the DVD
Perhaps the problem is that now the new dvd is AHCI, and it is a matter of drivers. Any idea as experts?

Did you run the media check from the cd/dvd menu?
It takes about 20 min’s give or take

see if it checks OK

Hello caf4926
Thenk you for helping me in this new world for me. Suse and linux
I am sure the dvd is OK, because I tried it in another computer and I could install Suse well. I have problems with the laptop. ANy advice?

Have a look here
Installation Help - openSUSE

But I would still run the media check. It seems like your drive is having trouble reading it!