Cannot install printer (Open Suse 13.1)

I have come back to Linux after a break of a couple of years, and installed Open Suse 13.1

It looks great but I cannot install either of my printers. I don’t really care about the Dell 1320c, because Dell never provided any Linux drivers for it, but I have a new Samsung ML 2165, for which Samsung provide a Linux driver on their website. Sadly it does not matter what I try I just cannot install it, or the universal driver that Samsung also provide. If I go to YaST the printer is detected if I click on “add” but no driver for it is found for it despite the fact that when you click on “find more” there are drivers for dozens of Samsung printers. I cannot however find one that actually works with my printer. The ML 2160 group of printers have been around for a while and all use the same driver. I really did hope that this new version od Open Suse would have it included. Does anyone have a solution that works or is it back to using Windows every time I need to print anything?

Did you try the driver from here?
ML-2165 - DOWNLOADS | SUPPORT | SAMSUNG (select ‘driver’ on left)

ULD contains a script which runs some scripts in /noarch. SUSE is mentioned.

There don’t seem to be any instructions. One of the scripts appears to check if you’re root so try running as root.

I tried that, but cannot work out how to install it. After download the file is easily unpacked. I got as far as unpacking it into Dolphin and opening a terminal, but have no idea what to do with it to get it to install. I have also found a Samsung universal Linux driver called “UnifiedLinuxDriver_1.01.tar.gz” I have loaded that onto a memory stick so that I can try it on both my computers, but again I have no idea what commands are needed to make it install. Examining the contents shows that a file named “autorun” contains a shell script as follows:

#! /bin/sh
BASE=dirname "$0"
exec sh “$BASE/Linux/”

On 2013-11-21 18:36, Norman E wrote:

> Does anyone have a solution that
> works or is it back to using Windows every time I need to print
> anything?

The thing to with Linux and printing, is before buying any printer
check that it works and is supported; which means that it is supported
by the community, not by the manufacturer.

Places to look at:

which redirects to


of Samsung printers

The 2165 is not even listed.

List of

The 1320 is not listed.

So you are out of luck.

Another solution I used previously is BUY the drivers from “turbo
print”. If they work the same way as years ago, you download their thing
and try it out. You can print anything, but you get their log in the
middle of the page, so it only serves to find out if they work. If you
are happy, you pay them and get a keycode to punch in and get the full

I have no idea if they would work for you or not. Just an idea. It
worked for me with my previous printer - the next one I verified it
works before buying it with free drivers.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

On 2013-11-22 11:16, Norman E wrote:

> #! /bin/sh
> BASE=dirname "$0"
> exec sh “$BASE/Linux/”

You have to get to a terminal, do “su -” and call that script by name.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

When you’ve unpacked ULD_Linux_V1.00.06.tar.gz you have a subfolder ULD. Then in a terminal

cd /home/<username>/<directory path>/uld
sudo ./

sudo because it has to run as root
you need the ./ because the current directory is not in the command searchpath; ‘sudo’ will give ‘ command not found’

‘sudo sh’ would also work because the command sh is in the search path

When I do that the script starts. I didn’t run it all.

Some instructions from Samsung would have been nice. I don’t know what you might have to do after this script ends; hopefully CUPS sees the printer.

Thank you all, I was going to use Dave’s instructions when I found this webpage The Samsung Unified Linux Driver Repository and discovered from the list of printers that my ML 2165 could use unified printer driver version 4.00.36 and downloaded it from here. The Samsung Unified Linux Driver Repository - Samsung Installer

After download it was all very easy, just a matter of unpacking the files in Ark, sending the folder to documents and then right clicking on the folder cdroot, selecting “open with file manager - Super user mode” putting in the root password and clicking the cdroot folder then autorun. This brought up an installer after which it was just a matter of following on screen instructions.

The website lists all the Samsung printers that can use the unified driver, and which versions of the driver they will use.

I have a samsung 1670ML myself. Huge problems with drivers, different distros, I found a minimalistic way a year ago:

  • Download the Samsung drivers and extract them. ‘cdroot’ usually name of directory.
  • Connect to cups with a browser: http://localhost:631/ Login as root
**Choose Administration & click ‘Add Printer’
…and select (mouse) Your printer. Now, provide a PPD File from the extracted directory:

Set default options (You can always change later):

Select ‘Printers’ in top menu. Cups is actually asking for the right file, so lets give him (?) that file.

Terminal/xterm as root: **

cp /PATHTO/cdroot/Linux/x86_64/at_root/usr/lib64/cups/filter/rastertosamsungsplc /usr/lib/cups/filter/ 

Done! You can print a test page right away under the ‘Maintenance’ drop down menu.****

I have Samsung ML-2165w (it’s the WiFi version) and it works like a charm in OpenSuse. Installation took like 2 minutes.

  1. Configure the printer to connect to your WiFi (I did it in Windows, it was the simplest and the fastest way to do it).
  2. Download driver from Samsung’s support page.
  3. Extract the archive and run sudo
    in terminal. 1. Go through the process, say yes whenever asked something. (The license agreement text can be closed by pressing q.)
  4. Go to http://localhost:631/
  5. Go to Administraton -> Add Printer
    (when prompted, login as root). 1. The printer should appear among discovered network printers (if not, check that both the printer and your computer are connected to the same network).
  6. Select the printer, click continue and just go through the process (next next next… I left everything to default).
  7. Done.

After that, the printer should appear among your system printers (I was immediately able to print a pdf from Okular).