Cannot install openSUSE / Stuck at green loading bar

Hi there!

I’m a windows sys admin and I’m trying to give linux a try. After much research, I chose openSUSE and I’m trying to get it installed on my laptop without much success.

I have tried creating the bootable usb in various ways as per documentation (ImageWriter, Universal Image Installer, UNetbootin, and Rufus).
Tried GPT, MBR, ISO Mode, DD Mode, DVD Image, Network Image.
Tried TPM enabled and disabled, Secure Boot enabled and disabled, Legacy and UEFI.
Tried on USB 3.0 and 2.0.

The usb boots normally, and I try choosing “Installation”, “Boot Linux System”, and “Check Installation Media”. All options load a green bar in 3 gradient colors (light, medium, dark green) up to about 80% of the way, close to the text "openSuse Leap 15.0.

I have left it there for at least 30min and there has been no progress. Unfortunately I cannot seem to find a “perfect settings combination” to make it run on this laptop. Am I missing something? Or is there something else that I could try? Or something I could do to troubleshoot this further and check any “log” to see at what step it is getting stuck at?

Here are my laptop specs:

  • i7-7700HQ 2.8-3.8 GHz
  • 16GB DDR4-2400
  • 256GB NVMe (no partitions) + 256GB SSD (no partitions)
  • NVidia GTX 1060 6GB

Any help is very much appreciated! :slight_smile:

Your difficulties are probably due to the Nvidia graphics.

The trick for getting around this, is to add " nomodeset" to the kernel options (the boot command). That switches to an alternative graphics driver. Once your system is up and running, you can look into installing Nvidia drivers.

How to specify a kernel option depends on whether you are using legacy MBR booting or UEFI booting. I wrote a blog post about that here:

I hope that helps you get the system installed.

That CPU i7 7700HQ reputedly includes Intel graphics, so that laptop may in fact be Optimus, and consequently in need of following the Bumblebee installation instructions. When installation completes using the nomodeset option, the first thing I would do is try booting without nomodeset, which can be tested by striking the E key when the Grub menu appears at boot, navigating to the line where it appears, and removing it before proceeding with boot. If performance is then acceptable, the proprietary NVidia driver and the nuisance keeping it up entails can be averted. The nomodeset parameter needs to be permanently removed, which can be done either via YaST -> Bootloader, or via cmdline by editing /etc/default/grub, followed by executing ‘grub2-mkconfig -o /boot/grub2/grub.cfg’.

I am having exactly this issue with Lenovo W530 which currently has LEAP 42.2 KDE installed in it. I checked the installation media several times, and everything checks out, except for the fact that it gets stuck during the load screen after selecting “install OpenSUSE Leap 15.0”

Did you try appending nomodeset to the linux line in the boot menu?

The nomodeset has indeed worked at the end. For some reason, I also had for a while an issue with the downloaded full *.iso packages as they failed verification during installation and eventually only net.iso worked.

When you are seeing green bars you can hit Esc button and watch text messages instead.
These text messages are much helper than “green bar stuck”.

No need to be concern, Nvidia often forgetting to certified their packages. You just have to accept the package to finish the installation.

I had similar issue with my new thinkpad-p1 installing openSUSE-Tumbleweed-DVD-x86_64-Snapshot20191230-Media.iso and adding “nomodeset” per your instruction worked perfectly. thnx.

Nvidia says hi to y’all folks! lol!

But why?! Nvidia always worked very reliable on Linux, what happened recent time?! For me even nomodeset does not help:


Nvidia does not release the full/complete specs of their hardware (for whatever reason It is for them to decide).
Anyways my old MSI laptop which has an Optimus GPU (intel +nvidia) has the same issue yours, starting from 11.4 iirc.
I always install from textmode


and nomodeset


as the kernel boot parameter, as of 15.1 the install will only work with the kernel safe settings plus my other two parameters.
I have a lot of practice using the text based yast2 installer so I can manage to finish the install (thank God!). Now the screen is fried and has no display it works with connecting a VGA connection to an external monitor, hdmi does not even work!


Something else was causing the installer to get stuck in my case: it was continuously trying to access the floppy disk drive and failing, retrying every 10 seconds or so…
Fixed by disabling the floppy disk drive in bios
I found out by pressing ESC during the ‘green loading bars’ phase as someone else suggested and checking the different consoles for error messages. The installer was stuck in the ‘loading basic drivers’ phase.
I also had to use the ‘nomodeset’ boot option otherwise the installer would not even reach the ‘green bars’ screen (yay Nvidia…)
Everything seems to work now

More info:
Mobo: Gigabyte GA-EP45-ED3P
CPU: Intel Q6600 @3200MHz
Ram: 4 x 2 GB Corsair DDR2
Gfx: GeForce 460 GTX
Iso: openSUSE-Tumbleweed-DVD-x86_64-Snapshot20201002-Media.iso

Hope this helps