Cannot install openSuse encrypted in a UEFI system


I have been trying to Install Opensuse with full disk encryption on a UEFI system.
I have tried Leap 42.1 and Tumbleweed but have received similar errors with both.
After the installation completes and the system reboots the computer boots to a GRUB command prompt, briefly displays one of the following two messages:


I would be ok with either leap or tumbleweed but i would prefer to get tumbleweed running.
I have read a few other posts of people having issues and some were able to get it to work seemingly by just copying a GRUB.efi file from 13.2 to there /efiboot however this did not work for me

Any ideas would be appreciated, my partitioning setup is below.

-Create boot volume /dev/sda1 (156.88 MiB ) with xfat
-Create encrypted volume /dev/sda2 (446.82 GiB)
-Create volume group system (446.82 GiB) from /dev/sda2
-Create logical volume /dev/system/root (444.82 GiB) for / with btrfs
-Create swap logical volume /dev/system/swap (2.00 GiB)


It should work. I have had that running with Tumbleweed.

You mention “xfat” for “/dev/sda1”? If you are using UEFI, then you need an EFI partition. As far as I know, that needs to be FAT, not “exfat”. But perhaps I am not understanding what you mean by “xfat”.

Does “/etc/default/grub” contain:


Also, are you booting with grub2 installed by opensuse, or are you using grub2 from another distro? I ask, because I tried installing kubuntu 16.04 that way, and it wouldn’t boot (similar messages to what you describe). However, I am able to boot it with the grub2-efi installed by opensuse (and careful boot configuration),

An additional comment. What you are trying won’t work with Leap 42.1 unless you add online repos during the install (specifically, the update repo). That’s because support was broken on the original release, though it should work once fully updated.


xfat or exfat is a Microsoft invention and it can be used on Windows and Mac.

1.exFAT allows for higher drive capacities than FAT32.
2.exFAT has a larger file size limit than FAT32.
3.exFAT uses a free space bitmap while Fat32 doesn’t.
4.FAT32 has greater support than exFAT.
5.FAT32 doesn’t have file number limits while exFAT does.

The things you learn on this forum :wink:

I’m aware of that.

But can it be used for the EFI partition? That partition is read by the firmware, and I seem to recall that the spefication call for FAT (with FAT32 recommended).

Okee. Dokee. I think Microsoft is trying to compete with Linux FS performance with exfat.

But you and I know Linux has them beat.

Please open bug report and post number here. Default LUKS hash has has changed, we need to add it to signed EFI image. Workaround is to disable Secure Boot support during installation (both in firmware setup and in YaST bootloader properties).