cannot install OpenSuse 11.2 at Dell latitude XT

I can’t install OpenSuse 11.2 on my Dell latitude XT notebook.

  1. I tried DVD x86-64 install. The process seemed ok, but after installing Suse can’t boot - with its any menu item. Booting seemed ok, there was no errors in screen lines, but when GUI seemed try to load (the screen became colored), all freezed. VGA menu item and other boot menu options did not save the situation. Repeat booting from DVD with Recovery option showed not mount or not correctly unmount fs (which couldn’t be corrected by recovery program), some not fatal difficulties in the core and other minor and correctable errors. But after recovery process the picture was the same.
    Sory for this describing, I’m a beginner at Linux, and decide to move to Linux from Windows, and choose Suse as better…:frowning: I can not yet mount fs or correct mounting problems from consol and do not know utilities for this from booting. Moreover, the installing process looks absolutely normal without errors, that begining at first booting…

  2. Then I tried net install. The same picture.

  3. Installing to clean hd… The same. (Manual partitioning - the same too.)

I will not describe my numerous different attemps (and wast time spent for net downloading), so far as I thought that the matter was in my adjustments in the istalling process, because other Linux distributives (such as Mandriva, Ubuntu etc. tried by me) were installed without the slightest problem at the Latitude XT.

  1. Then I downloaded and installed 11.1 version of Suse. There was only some minor errors, and booting was normal. But there appeared some problems with downloading from repositories and I couldn’t update it to 11.2; and installing 11.2 over 11.1 from DVD resulted to the same problems.

  2. After I searched this forum, I’ve tried different installing options (noacpi and so on) at last… But without any result and any change… :((

Please, help me. I easy installed OpenSuse 11.2 from DVD at my desktop without any error and I like it very much.

By the way, some more question about Dell Latitude XT:
Does there exist support for N-trig multi-touch for Linux? It would be splendid! Or maybe Wacom Linux drivers will work with this tablet?

Thank you.


I have exactly the same problem.
When installation of OpenSuse 11.2 on my Dell Latitude XT is finished the screen freezes and shows funny color patterns. The only possibility now is to shut the notebook down by pressing the “off”-button. No reactions on keys.

I used several versions of OpenSuse before (e.g. 11.0) and never had such problems.

I, too, tried different modes for booting (vga=normal, noacpi). It didn’t help.

A solution, anyone?

Thank you!

did you guys deleat windows yet, if not, did you have any problems with that. Did you try to run the Live CD to check your hardware?

It happens maybe in different cases, some of them:
1- what is the graphic card on the above mentioned Dell Latitude XT.
2- Did you tried to run Live CD and see if it detect every thing fine.

But preference still goes to No.1 above.

Video is ATI Radeon Mobility X1250.

Booting freezes independent of Windows partition existed.

PS: For me was surprise that OpenSuse cant install on Latitude XT in compare with other Linux such as (K)Ubuntu, Mandriva etc. They arose no one error while Suse cant install at all.

Where are you now in this?

First - I recommend you test first with the liveCD of openSUSE-11.2. Does it boot and run ok ? If not, then please advise, and we can provide some test sequences, that you can use to see where the problem lay.

Second - If you have a clean openSUSE-11.2 install on your hard drive, please advise. In that case, I recommend you boot your PC to run level 3 and try different driver combinations to see if you can find a graphic driver that works ok. You can do this, when the Grub boot menu (either a green menu, or a christmas scene menu) and type “3” (no quotes) so that “3” (no quotes) is added to the option line, with a space between it and the existing entry. Then press <enter> so the PC will boot the operating system.

That will take you to a full screen text/ascii log in. Login as a regular user and enter your password. Once logged in, type “su” (no quotes) to switch users to administrator (enter root/admin password).

Then check to see if your PC has an /etc/X11/xorg.conf file? If it does, delete the file (rm /etc/X11/xorg.conf) , and restart with “shutdown -r now”. Do you still have the problem?

If you do, then restart again to run level 3 (ie enter “3”, log in as a regular user, type “su” to get root permissions), and then then try various drivers by typing the commands below and testing each.

  • sax2 -r -m 0=vesa
    #vesa graphic diriver
  • sax2 -r -m 0=ati
    #old legacy open source free ati graphic driver
  • sax2 -r -m 0=radeon
    #open source free radeon driver
  • sax2 -r -m 0=radeonhd
    #open source free radeon hd driver
  • sax2 -r -m 0=fbdev
    #very very slow and old frame buffer driver

after each of those different graphic driver attempts, before trying the other, test the driver by typing “exit” (to get rid of root/admin permissions - that is IMPORTANT) and then once back to a regular user type “startx” (no quotes). If that works, immediately exit X window, and then restart with “su -c shutdown -r now” and enter root password. This time do not press 3 at the grub menu.

You can also, if worst comes to worst, from run level 3 as a regular user copy the file /etc/X11/xorg.conf.install to /etc/X11/xorg.conf ( su -c ‘cp /etc/X11/xorg.conf.install /etc/X11/xorg.conf’ ) and again try “startx” and see if that works. You will need to do that copying from run level 3.

Note anytime this works, you should restart your PC, as one does not get the proper permissions with “startx”.

Sorry, I’m newbie in Linux and Suse.

  1. I’d like to install Suse on my tablet, but can install only on desktop. Now will try to run live cd.
  2. Do you advise to copy partitions with installed Suse from desktop to tablet?..
    Sorry, I understand you, did not know earlier about level 3. Now I have installed Kubuntu on the tablet, so will study how not to break it, and then try this way.

If new to Linux, here is a page with some basic openSUSE Linux concepts: Concepts - openSUSE the page is very condensed with lots of information. I recommend you read that page.

Sorry, I do not understand what you are saying.

No if the Installer doesn’t run well on the tablet, then copying system over won’t run well either.

There has been an update to X (graphical display) since 11.2 GM, so it may be worth booting to run level 3 text mode. Then becoming root as described before, and then running “zypper patch” to apply updates.

You might find a better experience (in short term), running the stable 11.1 plus updates, and upgrade KDE4 (or GNOME) & Mozilla Firefox to newer versions post-installl (using 1-click install). 11.2 is still rather new and some time is needed for users like andrewsno1 who are familiar with system to report bugs and test on the latest release.

Note you can boot live CD to run level 3 by pressing F3 at the first green boot menu option, and select “TEXT”. Then boot the PC and it will take you to the run level 3 full screen login. Login in as user “linux” and press < enter > for password. Type “su” to get root permissions and press " < enter > " for password.

Then my previous sax2 suggests are applicable, EXCEPT with a live CD everytime you reboot you will lose your settings.

Also running
cat /var/log/Xorg.0.log | less while in level 3 may show where the problem is
pay attention to (WW) and (EE)

Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

Then this might be even simpler :

egrep 'WW|EE' /var/log/Xorg.0.log | less

Hitting CNTRL-ALT-F8 shows you recent logged messages to.

I’ve tried live cd. Standard booting was the same as with installing from full dvd - freezing. Next step was enter level 3.
I login as root. I didn’t find /etc/X11/xorg.conf file and didn’t restart between commands.
‘sax2 -r -m 0=vesa’ resulted in 7 lines of error ‘ISaX: could not import file: /var/cache/sax/files/config at /user/sbin/isax line 199’
and error ‘xc: sorry could not start configuration server’
‘sax2 -r -m 0=ati’ resulted in the same above 7 error lines, but then entered in graphic mode.
‘sax2 -r -m 0=radeon’ differed from previous only 24 bit color deepth (16 bit for ati).
‘sax2 -r -m 0=radeonhd’ resulted in the same freezing picture demanded rebooting.

Great thanks for help, what are my next steps?

I did a search on the X1250 on our forum, and I note many openSUSE-11.2 users having this problem. Purportedly openSUSE-11.1 works, but 11.2 does not.

I did find this bug report:
which indicates an update to the driver is needed.

I also found this bug report:
where the recommendation was to please add to your repos and update the radeonhd driver. This may fix your hang.

That “might” be possible to do if your Dell Latitude XT has LOTS of RAM. ie login to run level 3 as per above as a regular user (linux). Then type “su” to get root permissions (this order is IMPORTANT !! ) . Then type:

zypper ar xorg
zypper install xorg-x11-driver-video-radeonhd
zypper rr xorg

the above will only work with a wired connection to the internet which is active in run level 3

Then type “exit” to get rid of root permissions. Then try “startx” or “init 5”.

If neither of those work, try again, but this time after installing xorg-x11-driver-video-radeonhd try two of those various ‘sax2’ commands I suggested (ie “sax2 -r -m 0=radeon” and if that fails try “sax2 -r -m 0=radeonhd” )

Hi Everyone,

thanks for your help so far.

The Live-CD is booting on runlevel 3.

However, my installation won’t boot neither on runlevel 3 nor on 1,6 or 0. That’s rather strange.

The last line I see on the screen before it turns fuzzy is “Loading HAL daemon done”.

My next attempt will be to read through the logs on my harddisk in Live-OS.

I’ll keep you informed.

Did you try the xorg-x11-driver-video-radeonhd update to the liveCD RAM disk and then try to start X window?