Cannot install Nvidia using the "Hard way"

Tried installing nvidia using the hardway but got this error:

Had previously installed nvidia on my old computer using the “hard way” without problem so the steps should be correct.

nvidia-installer log file ‘/var/log/nvidia-installer.log’
creation time: Sun Jun 6 14:01:09 2010
installer version: 1.0.7

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : true
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 195.36.24.
-> Performing CC sanity check with CC=“cc”.
-> Performing CC version check with CC=“cc”.
-> The CC version check failed:

The compiler used to compile the kernel (gcc 4.5) does not exactly match the
current compiler (gcc 4.4). The Linux 2.6 kernel module loader rejects kern
el modules built with a version of gcc that does not exactly match that of t
he compiler used to build the running kernel.

If you know what you are doing and want to ignore the gcc version check, sel
ect “No” to continue installation. Otherwise, select “Yes” to abort install
ation, set the CC environment variable to the name of the compiler used to c
ompile your kernel, and restart installation. Abort now? (Answer: Yes)
ERROR: Installation has failed. Please see the file
‘/var/log/nvidia-installer.log’ for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at Welcome to NVIDIA - World Leader in Visual Computing Technologies.

Hardware:Thinkpad T410, NVIDIA Quadro NVS 3100M

Nvidia Package: NVIDIA-Linux-x86_64-195.36.24-pkg2.run

First try, saw same error (as above) and installed gcc-4.5 and linked it to gcc instead of gcc-4.4

Try again and got same error message (as above).

Any suggestions appreciated.

Which openSUSE version?

Problem is, that you want to compile the kernel module with a different version of gcc than the one your kernel was compiled with.

Maybe you should try to remove gcc44 before installing gcc (the 4.5) with zypper.

It might clean all environment variable related to gcc…

add nomodeset at the kernel entry line in /boot/grub/menu.lst and restart.

then try install nvidia driver.

Have you updated your kernel from a repo other than the oss repo for your distro version? This is an unusual error to get when compiling the nvidia module.

I doubt if installing an different version of gcc was the answer.

“nomodeset” works.

Oops, didn’t get any notification of the replies, anyway …

Which openSUSE version?

  • Milestone 7 (2.6.34-8-desktop)

Maybe you should try to remove gcc44 before installing gcc (the 4.5) with zypper.

  • removing gcc-4.4 will remove gcc altogether
  • installing gcc will bring in gcc-4.4 as a dependency
  • installed gcc-4.5 and linked it to gcc (ln -s gcc-4.5 gcc), nvidia install still fails

Add nomodeset at the kernel entry line in /boot/grub/menu.lst and restart.

  • tried but without success

Have you updated your kernel from a repo other than the oss repo for your distro version?

  • kernel from opensuse

So far, still unable to get Nvidia working >:(

same problem here and nomodeset works. but have to keep using that for each boot. i wonder what happened, all the previous os11.3 and kde4.5 updates have worked fine for nvidia ‘the hard way’

Building/installing nVidia Proprietary Video Driver in MS7 - openSUSE Forums

I just ran ‘zypper dup’ today for Milestone 7 and when I tried to reinstall the nvidia driver 256.29, I got the same error as the OP. I uninstalled xorg-x11-driver-video-nouveau and rebooted.

When I did

lsmod | grep nouveau

it showed the nouveau module was loaded! So I still get an error when trying to build the nvidia module. I’ll try blacklisting it later today according to oldcpu’s instructions and see what happens.

I have xorg-x11-driver-nouveau installed, yet blacklisted nouveau. NVIDIA driver installs fine, runs ditto. Point is to avoid the loading of the nouveau driver at boot, the NVIDIA driver cannot install properly since the nouveau driver ‘holds’ the card. So blacklisting should solve your problem, yes.

I followed oldcpu’s instructions from another thread and blacklisted nouveau:

echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf

I checked the blacklist.conf file to make sure nouveau had been added, then I rebooted. I still got an error when trying to build the nvidia module and nouveau still showed up in lsmod.

I booted again and added ‘nouveau.modeset=0’ to grub and I was able to successfully build the nvidia module. I loaded the module and started X and everything was working.

I rebooted again but the nvidia module didn’t load. I tried using the ‘nomodeset’ option in grub and the nvidia module loaded but my keyboard and mouse didn’t work.

I rebooted again with the ‘nouveau.modeset=0’ option and the nvidia module loaded and worked fine.

So nouveau is loading everytime despite the fact that I have uninstalled xorg-x11-driver-video-nouveau and blacklisted it. And I have to enter ‘nouveau.modeset=0’ at the grub screen everytime to load the nvidia module.

Do:


tail /etc/modprobe.d/50-blacklist.conf

and post output here.

Here you go

tail /etc/modprobe.d/50-blacklist.conf

# For some bridges both intel-agp and i82875p_edac are loaded. If i82875p_edac
# is loaded first it will grab the device. Then intel-agp doesn't work.
# Therefore we disable automatic loading of 82875p_edac. (Bug 213840)
blacklist i82875p_edac
#
# Blacklist the IBM s390 module for I/O dynamic configuration support
# Bug bnc#478601
blacklist chsc_sch
blacklist nouveau

I filed a bug report about this and the devs referred me to the release notes for Milestone 7 about how they’re switching to KMS.

From the release notes:

Technical

Initializing Graphics with KMS (Kernel Mode Setting)

With openSUSE 11.3 we are switching to KMS (Kernel Mode Setting) for Intel, ATI and NVIDIA graphics, which now is our default. If you encounter problems with the KMS driver support (intel, radeon, nouveau), disable KMS by adding nomodeset to the kernel boot command line. To set this permanently, add it to the kernel command line in /boot/grub/menu.lst. This option makes sure the appropriate kernel module (intel, radeon, nouveau) is loaded with modeset=0 in initrd, i.e. KMS is disabled.

In the rare cases when loading the DRM module from initrd is a general problem and unrelated to KMS, it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. Reboot your machine.

On Intel without KMS the Xserver falls back to the fbdev driver (the intel driver only supports KMS). On ATI for current GPUs it falls back to radeonhd. On NVIDIA without KMS the nv driver is used (the nouveau driver only supports KMS).

This still doesn’t explain why I still have nouveau after I uninstalled it, but oh well.

Maybe the nouveau module is in your initrd, so it is loaded long before any blacklist rule is applied. Try fixing it by rebuilding initrd with mkinitrd command.

No, graphic modules don’t go into initrd unless explicitly listed in INITRD_MODULES, which is rather rare anyway. GCC version does not play much of a role these days, mixing them is fine. But of course the nvidia installer is too stupid to get onto that. Given the frustration with their nonstandard selfmade installers, I only ever use the fixed src.rpms I made.