Cannot install Netbeans so it Runs

I am using OpenSUSE 12.1.

I have tried to install netbeans several different ways.

1/ I downloaded netbeans-7.2.1-ml-linux.sh and entered

sh netbeans-7.2.1-ml-linux.sh

The installation ran to completion and formed a file called

~/netbeans-7.2.1/bin/netbeans

When I enter ~/netbeans-7.2.1/bin/netbeans at the prompt, there is a delay while nothing happens and the prompt comes back.

2/ I try to install netbeans-platform using the Software Manager. I select everything that comes up when I enter netbeans in the Find box. Now

> whereis netbeans

returns

/usr/share/netbeans

which is a directory.

3/ I use YaST as outlined here. That gives me a netbeans icon among the Applications but clicking on it doesn’t do anything.

4/ I downloaded netbeans-6.8-ml-linux.sh and tried to install netbeans using

sh netbeans-6.8-ml-linux.sh

This result was the same as with sh netbeans-7.2.1-ml-linux.sh although the installation appeared to run without a hitch in both cases.

Any assistance with this would be greatly appreciated.

Peter.

Did you do this ?

                                               It's working finally. There were two libraries missing: openjdk-src  and openjdk-devel, after installing that via yast, everything ok :)                 

I tried that also uninstalled and reinstalled netbeans-6.8 after doing so. Same problems.

Thanks,
Peter.

please launch netbeans from your menu in KDE / GNOME/ LXDE /XFCE after installation through YaST / zypper

I clicked on the menu in the item. It just brought up one of the open windows such as FireFox or the Gnome terminal window. It did not launch netbeans.

Thanks,
Peter.

I fixed the problem. The installation should be

kdesu su netbeans-7.2.1-ml-linux.sh

I am wondering as to whether we need that extra “su” after kdesu ?

Sorry. It should have been sh.

Thanks,
Peter.