Cannot install GRUB on Z60T Thinkpad

So I’m installing 11.2 and I get all the way to the end (yay, but not for long). I get all the way to installing the bootblock and it says installation of the bootblock failed. This is a fresh install of 11.2, wiped out XP (I dont use Windows). This is the first time I’ve ever had this issue. Thanks in advance for the help.

What happens with the install, does it complete and run you thru the post install config. If yes, what happens at reboot?

Are you trying to install grub on the MBR or first sector of root partition?

I jumped the gun. It was late… lol. I installed 11.2 got the error and just shut it down. I booted it up this morning and it DOES have GRUB installed but I did get that error.

Is 11.2 ready for prime time or should I have installed 11.1 ?

I had a grub error like this on one of my installs and it worked at re-boot.

11.2 is way better than 11.1 IMO

thats what I needed to know :slight_smile: This place has always been helpful. Thank you guys for the info.

BTW, I did get a ahci error or somethin, I’m going to check that out later since I need to replace the keyboard on this thing (bought it used yesterday).


Good luck
ahci is fully supported in Linux, I have only ever had issue with it and XP

I havent tried troubleshooting that just yet… the 3,E,D,C keys are not working so I’m hoping my gamble of buying a replacement keyboard is the correct one. After I fix that I’ll be all over this thing to fix whatever needs to be fixed (ahci being one of them)