cannot install codecs/vlc

In my experience you should use the xine backend for audio playback.

Have you done an unconditional update in packman?

there is jack, oss, alsa, null, filewriter, and crossfade output plugins, how do i use xine?

i didnt do unconditional update in yast coz there’s no such option but i did update gstreamer packages with packman and now totem plays divx and vlc plays audion without break if i change plugin to alsa, but audacious plays bad with alsa so i changed to oss. this is way to weird, also when i play videos on youtube theres a scratch at the beggining every time, one second of white noise, very noisy.

Try removing, and then re-installing gstreamer-0_10-plugins-bad. Maybe it had a bad install. Take careful note of any dependencies removed if/when you remove gstreamer-0_10-plugins-bad, so you can install them back again.

What sort of internet connection do you have? I’m suspicious of a bad connection.

What is the output of
zypper lr -d

I would like to see what repos you have setup, so you don’t make the same mistake again.

A number of users have reported that loud “scratch” at the start of youtube videos. I had the same for a while, and then it disappeared. I HATE IT when that happens, as I don’t know what fixed it. Possibly a flash-player update.

youtube problem seems to be solved this way too. neat, thanks :slight_smile:

i dont like the 10 minute only edit option :stuck_out_tongue:

now i have only legit repos which you recommended. and i will check every now and then if the list changed.

what about xine? i just stopped audacious to play youtube, else it plays without audio, and when i go back to audacious it doesnt play, i have to restart it, plugin conflict?

Using gnome then eh.
Try this in a su terminal

zypper dup -r Packman Repository

ok, that did it. sound plays nice and clean in audio player. but. now vlc and totem wont play sound. i changed output plugins in vlc but still it wont play sound. i’ve seen some other topics on that so i’ll look into it.

What did it? Exactly.?
The zypper dup command?

I prefer mplayer with smplayer frontend.

You can adjust audio settings in VLC prefs - might help

Note that mixing packman and videolan repositories is almost a sure way for new users to break audio in vlc.

i disabled vlc repo after installing libdvdcss, i updated unconditionally via terminal with packman, i tried to changed vlc prefs, audio plays ok in decibel audio player, but not in totem and vlc, no sound at all, also in totem. vlc is suppose to have it sown codecs so why it depends on system plugins?

Are you trying here](

If you have not done so already, you could install from packman libffmpeg0 (it will pickup a bunch of codecs) and also w32codec-all.

Make certain you check the audio output mode as set in vlc.

ok, this is just plain weird. i swear i tried it before and it didnt work. now it works :slight_smile: i did a couple of restart though. hope it stays like that. thanks. i assume that noisy output is normal when playing both vlc and audio player right? coz they use same config or sth… and normally i dont want to use more than one player at a time.

@caf4926: i use gnome coz my computer is an old hag and cannot handle kde :slight_smile:

what is “audio player” ?

vlc is notorious for bad sound, if one over drives the audio too high. I keep vlc at around 15 to 20% max audio, and use the PC’s mixer to increase audio, not vlc’s audio control.

i use decibel audio player now, but i like audacious also. if vlc couses so many problems why it receives so much publicity. true, under windows it didn’t cause so many problems.

there is one more tiny problem, when i use audio player i sometimes browse thru youtube videos. if sth catches my eyes i want to watch it so i pause the player and play the video on youtube. but there is no sound. to get the sound i have to quit audio player and refresh the page. then if i want to go back to listening music i have to quit youtube before playing again sth in audio player.

I think you will find this is normal even if undesired. Though I don’t frequent Youtube and neither am I in the habit of starting more than 1 application needing sound.

this is not normal. before reinstalling the system i could listen both to music and youtube videos. you can also do both in windows. and if i start youtube first than the player wont play any music, hangs and i have to kill it.

It IS normal if you do not have specific sound engine/sound-API selected.

Possibly it might help if you read some sound concepts: Sound-concepts - openSUSE

From that you will read that most the sound engines/api’s on not just openSUSE, but Linux in general, do not share the sound device. In essence only alsa (and the new somewhat buggy pulse) api’s will share the sound device. For example OSS will not.

i started new topic on this. we somehat drifted away from the initial question. ok, then. if alsa and pulseaudio can share audio devices i want to be able to use either one. but, i cant since the sound is scratchy, noisy and with breaks when i use them. is there a troubleshooting guide on sound similar to this on video codecs? other than this: