Cannot install bootloader; boot partition is of type NFS

I haven’t tried installing because when I review the installation, this is what it says. I have Vista Business occupying my hard drive and a recovery partition for Vista. I want to install openSUSE as a dual boot. I’ve done dual boots on this comp before with ubuntu, but I like openSUSE more :cool:

Here is a screenshot of my install summary before it starts:

What does this error mean? All of my hard drive is occupied by Vista, but would shrinking that partition and creating unallocated space on my hard drive work better? That’s what I used to do for ubuntu, but I couldn’t find an option in the openSUSE installer to use the largest continuous free space.

Any help is greatly appreciated.


May I see your whole partition scheme?

To partition with suse’s disk:
click on the “change” menu.


same Problem here (HP Pavilion dv9695eg, German, Opensuse 11 64 Bit). I stopped the installation, because I don’t want to kill Vista or HP Recovery. It would be nice if someone familiar with Grub could give us a hint. Of course: Because I stopped installing OpenSuse, there is no fstab at all. Gparted shows the following:

/dev/sda 149 GB
/dev/sda1 ntfs OS 140GB - - boot
/dev/sda2 ntfs HPRecovery 7GB 5GB 2GB

/dev/sdb 149 GB
/dev/sdb1 ntfs DATA 149GB 20GB 129GB

Gparted is not able to read sda1 because it detects a bad sector, but this seems also to be an error (according to Vista the drive is ok).


is this what you wanted to see?

I can’t find a change menu anywhere.

I don’t use gparted or anything; I just use Vista’s disk management.
Right click on Computer, then click on manage. then Disk Management in the sidebar.

Then I right click the C volume and shrink it so I have unallocated space.

That’s how I know.

I’m going to try now with this unallocated space. It turns out that I’m not allowed to shrink C: more than 32.43GB or the pagefile won’t fit or something. I think that’s the problem I had because I kept trying to do 35 in OS 11’s installer.

is this what you wanted to see?

The image shows nothing, I want to know which partitions do you have currently?
I want to see something like this:

Disk 1:
Primary parition 1: 30 go for vista
Extended partition
Logical partition1 : 30 go free

Disk 2:

Based on what you have currently.

But I have just guessed the problem:

The problem, from what I seen in your image, is that you have creat new paritions, but you didn’t set mount point.

Grub installs is normally in 2 sections:
The first part is grub stage 1, installed in the master boot record.
The second part is grub stage 2, installed under /boot/grub
If no linux (ext3, reiser…)partition is set as / or /boot, then stage 2 cannot be installed.

Thanks for the help, but I won’t need to post the partition stuff.

I resized the Vista partition from Vista to make some unallocated space. It turns out Vista would only allow 34GB instead of 35 :expressionless:

Vista’s just as greedy as Microsoft…

Thanks for all the help. I now have openSUSE installed perfectly alongside Windows :slight_smile:

The openSUSE forums are just as good as the ubuntu forums! :slight_smile: :slight_smile: :slight_smile:


I am completely new to Linux, and chose open SUSE since itäs said to be a good beginners distribution.

I didn’t come far, though. Exactly the same thing happens to me. I go through the first steps of the installation. When it starts the system overview, it doesn’t find any hard disk.

If I go on through the installation process, in the last screen before installing to hard disk I get the same message: Cannot install bootloader; boot partition is of type NFS

I run only Windows XP, and don’t wish to create a double boot, just replace the Windows with open SUSE.

What to do?:\

Actually, my file system is NTFS.

In that case you should start a new thread with the correct title because NFS and NTFS have nothing to do with each other, other than being filesystems.

Thanks, I’ll do that. :slight_smile:

Just to be clear - My file system is NTFS. But the message the open SUSE installation program gives me is that I cannot install bootloader; boot partition is of type NFS.