cannot install because install medium can't see hard drive

I have a new ASUS Zenbook flip S UX371. The CPU is an 11th Gen Intel Core i7-1165G7 processor, and it uses the Intel Iris(R)Xe Graphics. I purchased a new 1TB SSD (that was NVMe and basically matched the stock), and put it in. My intent was to install 15.3 on this SSD, but when I booted into the 15.3 install usb stick, it could not see the new drive. I thought maybe it was because it did not yet have a partition table.

Looking at the bios screen, it shows that the drive is there. Not only that, I downloaded gparted and made a gparted boot disk. I booted into this, and it saw the empty drive sitting there without a problem. I used gparted to set it up with a GPT and then setup my partitions.

So the OS that gparted uses was able to see my new SSD, but the opensuse install system (once it was loaded) wasn’t able to see it. I tried booting into the rescue system from the USB stick, and it also could not see the new SSD when I ran fdisk -l.

I also tried disabling secure boot and running the rescue system, and the install, and in both cases it still couldn’t see the new SSD.

Am I doing something wrong?

I suggest you try Tumbleweed. Download a live iso, and see how that runs.

The reason I suggest this, is that Tumbleweed has a newer kernel than Leap. Perhaps your hardware needs a newer kernel.

Thank you, that got it to read the hard drive. I am installing Tumbleweed now.