Cannot graphically mount media and drives (they're missing)

I have tried both OpenSUSE 11 kde4 and Gnome, yet both of them, the file managers do not even show the option to mount any of the 5 or so partitions I have on the system.

Short of making a desktop shortcut that commands for e.g. “sudo mount /dev/sda1 /media/Windows/” There’s no real way to mount them.

When I plug in a usb or so, it (vfat) will ask me what I want to do, but when I turn on my esata-expresscard external drive, there is no option to mount that like there should be.

Is anyone having this same problem or recommends a fix?

Thank you

Not sure what you mean. With a normal install, OpenSUSE mounts all available partitions, including Windows, and you don’t have to mount them manually. Did you do an expert partition and fail to mount the partitions in the course of that?


please, with all drives plugged in, post your fstab and the result output of fdisk -l


I have an quite similar or the same problem. When I plug in my USB-HDD (and turn power on) Suse recognizes it and asks me, what I want to do. But if I choose something like opening the drive it says:

mount: wrong fs type, bad option, bad superblock on /dev/sdc7, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

The partitions on the drives are NTFS-formated.

Yes, I did an expert install both times and now I am in belief that that was the problem.

Here is my fstab:

brian@Inspiron:~> cat /etc/fstab
/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVS-_WD-WXE307H32559-part7 /        ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVS-_WD-WXE307H32559-part9 swap        swap       defaults              0 0
proc                 /proc                proc       defaults              00
sysfs                /sys                 sysfs      noauto                00
debugfs              /sys/kernel/debug    debugfs    noauto                00
usbfs                /proc/bus/usb        usbfs      noauto                00
devpts               /dev/pts             devpts     mode=0620,gid=5       00

here is my fdisk -l

brian@Inspiron:~> sudo /sbin/fdisk -l
root's password:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x7a695750

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        9896    79488000    7  HPFS/NTFS < Windows Vista
/dev/sda2            9897       19457    76798732+   5  Extended
/dev/sda5            9897       13812    31455238+  83  Linux < Ubuntu Hardy
/dev/sda6           13813       16511    21679686   83  Linux < OpenSUSE 11 Gnome
/dev/sda7           16512       19188    21501952   83  Linux < OpenSUSE 11 KDE4 (running)
/dev/sda8           19189       19196       64228+  83  Linux < Grub boot partition
/dev/sda9           19197       19457     2096451   82  Linux swap / Solaris

It isn’t that my partitions aren’t automounted, it’s that I can’t go to dolphin, nautilus, thunar, pcmanfm, Desktop>shortcut>device, etc to be able to mount a partition. They seem to be missing unless I go to the command line and mount them individually.

I have been very used to Ubuntu that has this feature of auto-detected partitions(and via GUI apps), does OpenSUSE not have that?

Also, I plug in an external hard drive through eSATA that holds my music. eSATA makes it appear as though it is an internal drive. However, it also does not appear anywhere unless I mount it through command line.

However, when I insert a usb drive, it pops up with a window asking me what I want to do (ie mount it)
Edit**: When I go to sysinfo:/ in Konqueror, it shows the drives, but when I click on them nothing happens and when I right-click on them, there is no option to mount them.

Thank you

@ CheesyBeef
Which filesystem are you using? Is it ntfs? I’ve had the same problem in Fedora 9 with ntfs-drives.

Try YasT->System->Partitioner and select a partition to edit. If no mount point is specified, e.g. on mine, Windows is /windows/C, specify one. If mount points are specified, then I cannot help you further.

Good tip. Just make sure that the mount point exists .e.g /windows/C before you set the mount point.

As I see in the Partitioner, my external drives are not mounted( have no mountpoint), but I can see them in Konqueror. It’s a newbe question, but how do I mount them? I never mounted Drives manually.



mount -t ntfs-3g /dev/blah_blah /mnt/yourmountpoint

or sometimes if ntfs was not shutdown neatly

mount -t ntfs-3g /dev/blah_blah /mnt/yourmountpoint -o force

be careful with force option…

for other options consult the man page

man mount

there is your problem, i can’t see the drives in fstab. either edit fstab manually for them, or as suggested above use yast partitioner to do it for you, ensuring mount point exists.

after that you should be all ok

@ idshark

Thx, I will try that. I think that this is an problem with ntfs, because there is an ext3 partition on the external-HDD which is mountet perfectly.

external drives are handled by hal and udev, so I don’t think that yast can configure it.

So what should I do?

“****”, I monted one of the partitions on the external-HDD manually and now are all datas from this partition gone.

Thank you for your help everyone. I am currently away from my system, so I will try some things when I get back to it.

Victor, you need to be careful. I wasn’t aware that you could destroy data with the mount command.

If you are trying to mount a partition, try following these steps - these are the safest to start with

find which partition you are trying to mount using this command:

sudo /sbin/fdisk -l

Then make a directory to mount that partition. For example:

sudo mkdir /media/disk

Try mounting the partition (using this method, the command line will alert you if it cannot mount the partition - it will not force unless u tell it to.

sudo mount /dev/sd-- /media/disk

Make sure you change the “/dev/sd–” to whatever disk you want to mount from fdisk -l (eg. /dev/sda1).

Good luck

Thx, I will try this when I’am back on my PC. Are these commands mounting the external-drives permanently or did I have to mount them every time I plug them in.
In Fedora 9 I’ve also had the problem, that I can’t start the system without the drives plugged in.

In an other forum, I’ve read something about an programm called “ntfs-config”, which can handle the ntfs drives.


Good news everyone, I’ve successfully mountet my external devices by using the programm “ntfs-config”. This programm recognizes automatically all mounted and unmounted ntfs-devices. It also let me set the access to the device.

Thx @ all


That usually means that you have those drives in your /etc/fstab file. If you want to start your system without them automounting, then go to your /etc/fstab and remove any lines that are for your external devices. Make sure to use fdisk -l to ensure you are removing the correct partitions.

I reinstalled OpenSUSE 11 Gnome and this time I used the guided GUI thing to set up my partitions. Now they are automatically mounted - which i don’t need - and I still can’t mount the partitions from my external sata drive that I have all my music on :frowning: (it’s not on all the time, so I can’t put it in my fstab)