Cannot get sound to work on freeciv on OpenSuse 11.1

Why is it so difficult for me to get sound on freeciv? At first, when trying to compile it myself, it was a challenge to get the configure script to locate the SDL header files. Once that issue was fixed, installation went through fine with support for SDL built in.

But now, when I play freeciv, it throws an error “Cannot open ***.ogg” whenever some sound needs to be played, even though the ogg files are present in the right path.

What am I missing? Since the files are there in the right path, I’m beginning to think that maybe freeciv is having problems playing ogg format and hence the “cannot open” error.

I even tried installing freeciv rpm from OpenSuse Builds and the issue is still there.

Does anyone have freeciv working with sound on OpenSuse 11.1?

Thanks in advance.

An update:
This problem, or at least a variant still exists in OpenSuSE 11.3. A bit of a disappointment for a game which was fully working for me when it was part of the default install of OpenSuSE (was it 11.0 or 11.1? - Can’t remember). Since then, freeciv has been actively developed into IMO unquestionably one of the best turn-based strategy games anywhere(when working), free or not. So, why did it get dropped from the default install once the bugs were mostly worked out and the AI and gameplaying was vastly improved?

First attempted a build from source from the site. Unfortunately, the listed system prerequisites seem to be faulty, I ended up with a mess where something actually launches but doesn’t look as it should much less do anything expected. Compilation generated no errors.

Next, (after make uninstall of course) I installed from the OBS Search Results

Current OBS package as I’m writing is latest current stable release of freeciv, v 2.2.4-1.1

The game installed and plays well, except…
No music.
Sounds do work, but music (which requires STD support) does not.

I have determined that I have a number of STD libraries already installed in my system, but I suspect some kind of “linker” app(eg player) is needed for freeciv to access the libraries… and I can’t find anything that describes exactly what to install and/or configure.

BTW - I found it odd that there doesn’t seem to be a specific way for Users to provide feedback to OBS projects the same way there is on sourceforge or freshmeat projects, so I can’t send a message or post somewhere a person on the OBS project will see.