Cannot get into KDE after update


Two days ago my system (11.3) was running fine with KDE 4.5.1. I received an update notification from the applet and installed the change (it was only one package, but I dont remember its name…it wasnt a kernel though). When I tried to boot yesterday, I can only login to the console.

I dont have any special repositories installed next to KDE 4.5 and Packman.

I did had trouble with duplicate kernels last week when I installed the latest ati-driver. I had default and desktop kernels installed. After removing default everything worked fine…until the update mentioned above.

Any ideas on that? In which log should I take a look for example?


Are sure Ati driver and kernel-flavour are still matching?
Maybe you can find something out if you look into your Xorg*.log.

I will look into this, thanks for the hint.

I also just did a zypper up and it updated 200 packages (mostly kde) but it didnt help.

I will also try to uninstall the display-driver and reinstall it. But its kind of weird because the configuration was working smoothly for a week now.

find /lib/modules -name "fglrx.ko"

  • If you have this file here /lib/modules/, try to add the option ‘nomodeset’ in the entry booting kernel-desktop in /boot/grub/menu.lst, as in that example:
kernel /boot/vmlinuz- root=/dev/disk/by-uuid/e764236e-b759-41ea-b927-ae33523b3916 splash=silent quiet showopts nomodeset vga=0x345

However you shouldn’t need that with fglrx (with radeonhd you would).

the above recommendations should work. if not, you can find out what update caused this problem by looking it up in /var/log/zypp/history (the one before your last 200-package-update).


Thanks for all the hints.

I fixed it by uninstalling the display-driver and reinstalling it.

I am using this neat script (German): openSUSE 11.3 – proprietären Grafik-Treiber ATI Catalyst 10.9 als RPM installieren

which has some nice options as well (like uninstalling).

Obviously one the updates last week did some kernel update which I didnt realize, thus I needed to rebuild fglrx.