Cannot enter home directory. Using /

I’m getting the message “Cannot enter home directory. Using /” when I login using my main account.tter that mge essa
right after that message I get the message " call to lnusertemp failed (temporary directories full ?).Check your installation" and my login fails and i’m sent back to the login screen.

I believe the error is caused because my /home which should be on my /dev/sda8 isn’t readable/visible to my acc. when i login as root this is my mount

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=8179820k,nr_inodes=2044955,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
/dev/sda7 on / type ext4 (rw,relatime,data=ordered)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
/dev/sda2 on /boot/efi type vfat (rw,relatime,fmask=0002,dmask=0002,allow_utime=0020,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
gvfsd-fuse on /run/user/0/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=0,group_id=0)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda8 on /run/media/root/228ba7ca-dca5-49f5-929c-8919f52bf4f3 type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
l

please help i’m a nub/noob.

On 2015-09-01 01:46, susenub wrote:

> I believe the error is caused because my /home which should be on my
> /dev/sda8 isn’t readable/visible to my acc. when i login as root this is
> my mount

Home is not mounted at all, so you have to find out why.

Maybe you can paste the contents of /etc/fstab


>   /dev/sda8 on /run/media/root/228ba7ca-dca5-49f5-929c-8919f52bf4f3 type ext4 (rw,nosuid,nodev,relatime,data=ordered,uhelper=udisks2)
>   l

See? sda8 is not mounted at /home. It seems an external disk :-?


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I suspect that you have loged in in the GUI as root… When that is the case, please NEVER do so.

I’m currenntly logged in as root not the user that’s locked out so i’m nnot sure sda8 is supposed to be home but i know that the files there are my accounts files.’
fstab


/dev/sda5 swap                 swap       defaults              0 0
/dev/sda6 /                    ext4       acl,user_xattr        1 1
/dev/sda2 /boot/efi            vfat       umask=0002,utf8=true  0 0
/dev/sda7 /home                ext4       acl,user_xattr        1 2


found a more detailed verbose error log for anyone interested

/etc/X11/xim: Checking whether an input method should be started.
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
Failed to connect to the VirtualBox kernel service
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
Can't create dir /home/shz/Desktop
Can't create dir /home/shz/Downloads
Can't create dir /home/shz/Templates
Can't create dir /home/shz/Public
Can't create dir /home/shz/Documents
Can't create dir /home/shz/Music
Can't create dir /home/shz/Pictures
Can't create dir /home/shz/Videos
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
grep: /home/shz/.gnupg/gpg-agent.conf: No such file or directory
Unable to create /home/shz/.dbus
Unable to create /home/shz/.dbus/session-bus
trying to create local folder /home/shz/.kde4: Permission denied
mkdir: cannot create directory ‘/home/shz/.kde4’: Permission denied
mkdir: cannot create directory ‘/home/shz/.kde4’: Permission denied
mkdir: cannot create directory ‘/home/shz/.kde4’: Permission denied
/usr/bin/startkde: line 76: /home/shz/.kde4/share/config/startupconfigkeys: No such file or directory
trying to create local folder /home/shz/.kde4: Permission denied
/usr/bin/startkde: line 119: test: : integer expression expected
cp: cannot create regular file ‘/home/shz/.gtkrc-2.0’: Permission denied
sed: can't read /home/shz/.gtkrc-2.0: No such file or directory
mkdir: cannot create directory ‘/home/shz/.config’: Permission denied
cp: cannot create regular file ‘/home/shz/.config/gtk-3.0/settings.ini’: No such file or directory
sed: can't read /home/shz/.config/gtk-3.0/settings.ini: No such file or directory
mkdir: cannot create directory ‘/home/shz/Desktop’: Permission denied
cp: cannot create regular file ‘/home/shz/Desktop/’: Not a directory
cp: cannot create regular file ‘/home/shz/Desktop/’: Not a directory
cp: cannot create regular file ‘/home/shz/Desktop/’: Not a directory
cp: cannot create regular file ‘/home/shz/Desktop/’: Not a directory
sed: can't read /home/shz/Desktop/Support.desktop: No such file or directory
cp: cannot create regular file ‘/home/shz/Desktop/’: Not a directory
mkdir: cannot create directory ‘/home/shz/.kde4’: Permission denied
cp: cannot create regular file ‘/home/shz/.kde4/share/apps/konqueror/bookmarks.xml’: No such file or directory
mkdir: cannot create directory ‘/home/shz/.kde4’: Permission denied
cp: cannot create regular file ‘/home/shz/.kde4/share/apps/akregator/data/feeds.opml’: No such file or directory
cp: cannot create regular file ‘/home/shz/.directory’: Permission denied
/usr/share/kde4/env/startkde.suse.sh: line 118: /home/shz/.kde4/share/config/nepomukstrigirc: No such file or directory
mkdir: cannot create directory ‘/home/shz/.skel/’: Permission denied
touch: cannot touch ‘/home/shz/.skel/kdebase4.120’: No such file or directory
Error setting value: Configuration server couldn't be contacted: D-BUS error: Can't overwrite existing read-only value: Value for `/desktop/gnome/url-handlers/http/command' set in a read-only source at the front of your configuration path
Error setting value: Configuration server couldn't be contacted: D-BUS error: Can't overwrite existing read-only value: Value for `/desktop/gnome/url-handlers/https/command' set in a read-only source at the front of your configuration path
touch: cannot touch ‘/home/shz/.skel/kdebase4firefox.120’: No such file or directory
touch: cannot touch ‘/home/shz/.skel/kdebase4.wallpapercache.113’: No such file or directory
mkdir failed: : Permission denied
startkde: Call to lnusertemp failed (temporary directories full?). Check your installation.


On 2015-09-01 18:46, susenub wrote:
>
> found a more detailed verbose error log for anyone interested

No, those entries do not matter. The are caused by, not cause of.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

On 2015-09-01 17:46, susenub wrote:

> I’m currenntly logged in as root not the user that\s locked out so i’m
> nnot sure sda8 is supposed to be home but i know that the files there
> are my accounts files.
>
> fstab
>
> Code:
> --------------------
>
> /dev/sda5 swap swap defaults 0 0
> /dev/sda6 / ext4 acl,user_xattr 1 1
> /dev/sda2 /boot/efi vfat umask=0002,utf8=true 0 0
> /dev/sda7 /home ext4 acl,user_xattr 1 2
>
>
> --------------------

Well, your problem is that fstab lists sda7 as home, not sda8. You have
to edit that entry with the correct one.

How this was changed, I have no idea what you have done with your system :slight_smile:


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

If you installed Windows recently it sometime creates an additional partition(s) which on a GPT partitioned drive also may change the numbers of the following partitions.

I fixed it by adding sda8 as a /home in fstab.
Now I have two partitions mapped to / though.
I have no clue if sda6 is needed its probably not and from me messing up the dualboot win install. How can I verify?

Thanks to everyone who replied I have access to my account.

On 2015-09-01 23:16, susenub wrote:

> I fixed it by adding sda8 as a /home in fstab.
> Now I have two partitions mapped to / though.
> I have no clue if sda6 is needed its probably not and from me messing up
> the dualboot win install. How can I verify?
>

Please post again your fstab file.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))