Cannot enable interface wlan0

hi there. my wireless adapter isn’ working. when i tried to /etc/init.d/network restart it says

RTNETLINK answers: No such file or directory
Cannot enable interface wlan0.
interface wlan0 is not up

what can i do ?

device: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

  • h R n,

please check the stickies in the network-internet wireless forum.


it won’t help beacuse i’ve used this device before. after installing ati driver like these below it won’t work anymore.

  1. install OS 11.2

  2. Log in as normal user

  3. Open up a konsole session in KDE, su to the root account

  4. type in or copy\paste this:

zypper in kernel-source kernel-desktop-devel linux-kernel-headers kernel-syms module-init-tools make gcc

Note: Change kernel-desktop-devel if you dont have the standard desktop kernel

  1. Download the 9.11 driver from the ATI website (9.12 kept causing my KDE to freeze)

  2. Go to the folder where you downloaded the driver to and run this command: sh
    Just leave everything at their defaults and let it install.

  3. Once the install has finished, run this command from a konsole user as root as well: aticonfig --initial

  4. Reboot to let the drivers load

  5. Log into KDE and enable desktop effects from the ‘configure Desktop’ app (Desktop sub-menu). If it keeps disabling itself, check the ‘Disable functionality effects’ from the Advanced tab.

  6. If you have dual monitors (which I do) start up a konsole window and su to root. Type in ‘amdcccle’ to open the ATI catalyst console and configure the placement of your monitors (which one is center, left or right etc) and configure the multi-display for 'Multi-display desktop (with display X) for both monitors.

i ran sax2 command. not aticonfig --intial and my vga driver successfuly installed. anyway… in netwok devices i can see device. in lspci i can see in the list. i deleted at yast then reboot and it didn’t work. with command /usr/sbin/iwconfig i got these

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

vboxnet0 no wireless extensions.

and after i ran this command sudo /usr/sbin/iwlist scan i got these…

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Interface doesn’t support scanning : Network is down

pan0 Interface doesn’t support scanning.

vboxnet0 Interface doesn’t support scanning.

did you see ??? THE NETWORK IS DOWN… what does it means network is down ??? now i’m connect with eth0 it works but wlan0 is down. these sticks helps people who drivers isn’t loaded or installed successfully it won’t help me. i wish i’ve never tried 11.2 because it has A LOT OF BUGS… i used 11.1 and it works instead of 11.2. what am i gonna do now ??? can you understand my problem with these ???

kernel is
my network manager is wicd 1.6.1

On 11/30/2009 08:56 AM, h R n wrote:
> kernel is
> my network manager is wicd 1.6.1

Perhaps the problem is with wicd. I do not use it and cannot help you
with it.

thanks man. i uninstall it and try with knetwork…

i uninstalled wicd and try it knetwork… /usr/sbin/iwlist scan command still says network is down for wlan0. what should i do friends ?? there must be something to solve this…

I have this same error as sometimes my wlan adapter gets down and the only way to enable it is by reboot.
This with your same card model.

Any suggestion???

Nowhere in your post do you say you did some basic things. Here is what I mean:
go to yast–>Network Devices–>Network Settings
click on your wireless card and select the tab at the top that says Global Options.
Click on traditional method (ifup)
click ok to finish

Open up a terminal
Type su and put in your password
type ifup wlan0

If you get no error message, you should now be connected.

I would use NetworkManager or wicd to control your connection. Both work for me in 11.2