Cannot enable desktop effects - NVIDIA GeForce 8400 GS

Alright, I input the sax2 command exactly how you told me to. I just went to the konsole and did “su”, to get root permission. Then entered what you wrote, and it went to a loading screen and asked for my user name and password, but didnt give me enough time to input both. Then the sax2 loads up and I try changing my resolution to 1280x1024, just how I have it in windows vista, then I save it. I then restart and nothing has changed, except now I cant use any desktop effects because the composting has been turned off and says “Composting is not supported on your system. Required X extensions are not available.”

When Im booting into sax2, this is what it says in the terminal–

SaX: access to your display has been granted
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
SPP: prepare device [0] profile: Depth24
SPP: prepare device [0] profile: NVidia
SPP: calling device [0] profile script: NVidia
SPP: prepare device [0] profile: NoModelines
SPP: prepare device [0] profile: NoComposite
SPP: including prepared profile(s)…
SPP: prepare device [0] profile: nobus
SPP: including prepared profile(s)…

SaX: startup
SaX: X-Server: :0.0 → grant
SaX: using cache data…

No. Thats NOT what I told you to do.

If you read the article link I provided it does NOT say to do this from konsole. That is a bad idea.

You need to BOOT the PC direct to run level 3 to get a full screen terminal mode.

Is there anything about that you do not understand that requires further explanation?

I just recently swapped out my old ATI card for a geforce 7950gt. After boot up the system correctly identified my card, i think with the nv driver. I them went straight to the “HOWTOs - openSUSE” page, scrolled down to section 4, Kernel and Hardware to 4.2 Graphics and clicked, then clicked on Nvidia – the HOWTO guide to Nvidia graphics cards. (Boy, what a genius I am.)

At the top of that page is a message that the page is under review, but if you click the link under Propriety Information for Nvidia drivers it takes you straight to the page with all the information and links you need to get your nvidia card working.

Since the 8400 is a geforce 6 or later (ie 6xxx, 7xxx, like 7950, 8xxx, like 8400 gs, etc.) you can use the one click method or the repository method, both well explained; well, there’s nothing to explain about one-click. Since I had never tried it before I did the one-click, which did install the driver, but doesn’t tell you much about what’s going on, as the repository method does. You have to either logoff/login or reboot, which it doesn’t tell you. I rebooted and everything works fine. Under systeminfo the driver is shown as nvidia. That’s all there is to it. BTW, in the post above where the poster says it says the driver is unknown I see the line that says: Driver: nvidia. So he did have the nvidia driver loaded.

Now I am using desktop effects just fine, which I couldn’t before because of frequent freezeups. To the best of my knowledge you must use the proprietary nvidia drivers to do this, or at least to do it without any problems.

Note also that to the best of my knowledge you do not use sax2 with the proprietary drivers; sax2 is for the open source drivers which ship with xorg/x11. All the linux users I know have nvidia cards and use the proprietary driver as it gives the full functionality of the card and works better.

Linux user for 3 months now, openSuSE 11.2, kde 4.3 and very happy with it. Have had only a few problems I could not smoke out by reading the forums and the online suse help and howto’s; Oh, yeah, and reading the manual. And most of those were from trying to get the ATI card to work right.

My apologies. I re-did the command in runlevel 3, and still nothing. I change the settings and it says that it will be updated the next time the graphics something is used(something along those lines), which I figured would just be a restart, so I reboot using shutdown now -r, then when I boot back into SuSE, nothing has changed. Sax2 has my monitor set as 15 in when its 15.4, I changed that also, after running the sax2 -r -m 0=nv, command and it just changed itself back. I dont get how this is so difficult, unless its only me whos making it that?

Ok I followed your instructions I typed in rpm -qa ‘driver’ in normal mode and I got this.


Sax2 -r

Chip: 0 is -> NVIDIA GeForce 8400 GS 01:00:0 0x10de 0x0422 AGP nvidia

from the sax2 -r I tried

sax2 -r -m 0=nv and sax2 -r -m 0=nvidia and I got this:

SaX: initializing please wait…
SaX: your current configuration will not be read in

SaX: wrong module syntax…
SaX: syntax: -m CardNr=CardModule,…]

i got that message for both of them.

when i tried sax2 -r i got this error message:

Error: XsyncBadAlarm 166
Extencion:164 (unknown Extencion)
Minor Upcode: 11 (unknown Request)
Resource i-d: 0x0

I also noticed that in the system info it now says:
Vendor: nVidia Corporation
Model: GeForce 8400 GS
Driver: Unknown

it use to say:
Vendor: nVidia Corporation
Model: GeForce 8400 GS
Driver: nv

thanks. -Julio

wrong model syntax … hmmm. … Note “nvidia” is for the proprietary graphic driver and should only be used if the “proprietary” graphic driver is installed. The link I provided makes that clear.

Also note that for “sax2 -r -m 0=nv” that is ZERO equals nv. i.e. the number zero.

That message suggests to me you are using a letter when you should be using a number.

I did not read the whole thread and I don’t know if somebody already provides a solution … But to install the nvidia proprietary driver for your graphic card from the Nvidia repository, just type :
zypper in x11-video-nvidiaG02
It should install the driver, compile the kernel module and write the appropriate /etc/X11/xorg.conf. After reboot, the nvidia module should be loaded (in doubt, type : lsmod | grep nvidia ) and the nvidia driver will be active.
I have two machines with GF8400GS and that’s how I install the nvidia driver on openSUSE. The reason why I used this gfx Card is that it is also supported byt the nv driver (not all models are) and I need that on other true open source Unix ( for which none proprietary driver exists). However I don’t know if desktop effects are working with the nv driver (and if so probably not as well as with the proprietary one :frowning: )

rpm -qa | grep nvidia

To use The Nvidia repo, copy/paste the following in the file /etc/zypp/repos.d/Nvidia_Repository.repo :

name=Nvidia Repository

I tried to find the file Nvidia_Repository.repo and it wasnt in the repos.d folder. What does that mean?

It means that it is not installed, which is normal, since this repo in not installed by default. I just told you the quickest way to enable it. If you don’t trust this method, you can use yast to add repositories.

When I said “copy/paste the following in the file /etc/zypp/repos.d/Nvidia_Repository.repo”, I meant that you have to create this file. Ok, sorry, it wasn’t that obvious. The name “Nvidia_Repository.repo” is arbitrary too. You can give it another name if you like, but that one seems logical.

Ok, I went into YaST and installed the nvidia driver. I then restarted and when it came to the boot menu, I have an extra two options( normally I have either OpenSUSE desktop, failsafe, and windows). Now I have two opensuse and failsafe, but theyre different. So I booted into the new one, and got a flash fo the big nvidia icon, then it booted into suse normally. All my desktop effects are back, but I still dont have the option for 1280x1040, like I have it set in windows. I also still cant active the 3d cube effect for switching desktops. I just want to be able to set it to 1280x1040 reso. It’s max is 1280x800 right now, and everythings just way too big.

Try to run nvidia-settings and see if you can change the resolution under X Server Display Configuration.

Yes, I tried that, and the maximum resolution is 1280x800. And I need to it to be 1280x1024. But theres no option for that, anyone know why?

More likely because your monitor is not recognized or send a wrong information to the driver. In both cases, it’s not fun.
See if you can change the model of your monitor in Yast. If your monitor is not there, choose something like Generic Vesa which can do 1280x1024 resolution … or rather Generic LCD, I guess.

It’s not cool because 1280x1024 is a very common resolution. Usually you have such issues with bigger resolution like 1440x900 or 1600x900 or 1680x1050 .

I guess programs like YaST and Sax might help to get the right settings. Otherwise it will require some handwork and some help. Basically, you will have to add Horizontal Sync and Vertical Refresh, Displaysize, probably disable EDID (so the monitor will not try to tell the driver what it is), set the preferred resolution, maybe add a modeline in /etc/X11/xorg.conf. With all this informations in the right place, it will work. But I understand that it might sound like a nightmare today. :frowning:

But you’ll get it done at the end.

Here’s a short example for a LG ELECTRONIC L1730S. If you happen to have such one, you’re lucky. You can take most of this values EXCEPT HorizSync, VertRefresh and DisplaySize which are specific to your monitor (there probably not very different but please DON’T try those!) and PCI:1:0:0 which is specific to your gfx card and mainboard PCI Xpress slot. I repeat: It’s an example!

# **********************************************************************
# Monitor section
# **********************************************************************

Section "Monitor"
  Identifier    "LGL1730S"
  ModelName     "LG ELECTRONICS L1730S"
  VendorName    "GSM"
  HorizSync     30-83
  VertRefresh   43-75
  DisplaySize   338 270              # 96dpi@1280x1024
  Option EDID "false"
  Option        "DPMS"
  Option       "PreferredMode" "1280x1024"

Section "Device"
  Identifier	"GF8400GS"
  BoardName	"GeForce 8400GS"
  VendorName	"nVidia Corporation"
  BusID		"PCI:1:0:0"
  Driver	"nvidia"
  Option	"dpms"
  Option	"NoLogo" "True"
  Option	"DPI"	"96x96"

# **********************************************************************
# Screen section
# **********************************************************************
Section "Screen"
  Identifier	"Screen Single"
  Device	"GF8400GS"
  Monitor	"LGL1730S"
  DefaultDepth	24
  SubSection "Display"
    Depth	24
    Modes	"1280x1024"		

Now that you know what you’re looking for, let’s hope YaST can write it for you.

how did you get the desktop effects to work with that graphics card? i did exactly what you did but i still cant get compiz to work. =(

can you please help. thx -Julio

For my athlon-2800 with a PCI (not PCI-e but PCI) nVidia 8400GS graphic card on openSUSE-11.2 (with KDE-4.3.4) I installed the nVidia driver “the hardway” (although its not hard). URL is here: NVIDIA/The hard way - openSUSE

Before installing the proprietary graphic driver I ensured I had kernel-source, kernel-syms applicable to my kernel version installed, and linux-kernel-headers and the 11.2 base development pattern installed/selected.

I then downloaded the nVidia proprietary graphic driver: NVIDIA DRIVERS 190.53 Certified

and then booted to run level 3 directly (not via init3, but rather direct to run level 3 from PC switch ON), and then with root permissions installed it:

sh -q

I removed my old xorg.conf, and then created a new one with:


and rebooted and everything worked.

My xorg.conf file looks like this: - nVidia GeForce 8400gs xorg.conf from oldcpu . That URL is good for only 1 month.

Note this is for a 26" monitor connected via a DVI interface to the nVidia 8400GS graphic card (via a DVI KVM switch) and I am running at a resolution of 1920x1200.

I’m no expert on the proprietary driver. I’ve NEVER installed via the repository method, so i can not comment on whether that is compatible with the “hard-way” … etc … The above simply worked for me.

Good luck, and sorry that I can not help more.

Actually I’m not a big fan of dancing windows either (as somebody recently wrote in this forum). So I don’t use desktop effects myself, but I just enabled them to answer your question. It works in both, Gnome and KDE. You just have to enable them from KDE Personal Settings or Gnome Control Center. I’m sure you did that already.

If the Nvidia driver is correctly installed and used (which you can see in the output of cat /var/log/Xorg.0.log | grep NVIDIA )
and you have Xinerama turned off (See cat /var/log/Xorg.0.log | grep Xinerama ), it should work. I don’t know if I’m forgetting something.

ps -C compiz will tell you if a compiz process is running

I always install the proprietary drivers (Nvidia and ATI) from the repos. Both repos are OK (at least at the moment) :

name=Nvidia Repository

name=ATI Repository

Most users won’t need “keeppackages”.

I cannot enable desktop effects in OpenSuse 11.2 with my ATI Radeon Mobility 9000 (aka FireGL 9000) card. The screen just goes black with a white cursor left. I cannot recover, a hard restart is required.

I posted about this and no one seems to know what’s going on or how to fix it.

Some people here are recommending ATI cards?!? Wow. That makes sense (sarcastic face).

All the tests recommended works out:
direct rendering = yes
glxgears - worked - giving 9xx FPS (i.e. 900+)
OpenGL version string: 1.3 Mesa 7.6

But, actually enabling 3D Desktop Effects crashes X and cripples the user.

I don’t know how well Nvidia works on laptops on Linux but I’m inclined to think it works better than ATI. However, on OpenSuse, who knows… :expressionless: