Cannot enable desktop effects - NVIDIA GeForce 8400 GS

I just added a new NVidia graphics card (PCI) that’s 512 RAM, DDR2, the GeForce 8400 GS.

OpenSUSE boots fine and shows the desktop but it tells me I cannot enable desktop effects, which should be no problem with this computer and card.

Computer Processor/RAM:

AMD Sempron™ Processor 3100+
Speed: 1,808.49 MHz
RAM: 1.4GB
Swap: 2GB

Graphics Card (from sysinfo):
Vendor: nVidia Corporation
Model: G98 [GeForce 8400 GS]
Driver: Unknown

Some of the things to determine is, did you configure your new card or did you install the card driver?

Looks like you didn’t install nvidia driver.

Sounds like your still running the nv driver? Check the ‘Driver’ output

hwinfo --gfxcard

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 1:13, 3 users, load average: 0.16, 0.11, 0.13
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Yep! I didn’t know I needed to do that (since it said it was using NVidia) but for anyone else encountering this:


6tr6tr wrote:
> but for anyone else encountering this

as far as i know no one should expect to be able to remove one
graphics card (or sound card) put in another and it work without doing
something to ensure the driver matches the board…

even with ‘easy’ Redmond software it is necessary to read and follow
the directions…like insert an install disk and . . .

same in Mac and Linux…


… easy … hmmm… EASY ? … if I may be forgiven for going off topic a wee bit, … on Saturday (26-Dec), my wife was noting that the new WinXP install on our 1-year old Dell Studio 1537 laptop (which we installed to replace Vista) was crashing with a bluescreen of death, followed by a reboot a bit too frequently. Note Dell do NOT support WinXP on this laptop (they actually provide better Linux support for this laptop) and we both noted that the WinXP ATI graphic driver for the Radeon HD3450 that we installed (as recommended by other’s on the web) was version 8.x something, when there is 9.x something now ready for ATI Radeon HD 3400 series devices.

So we downloaded an installed the latest WinXP 9.x catalyst driver from ATI, very carefully following the ATI instructions for the install. Well, as soon as the driver was installed, the FONTs took a SIGNIFICANT turn for the worse, appearing fuzzy and a bit out of focus. My wife hated it and after over an hour of fiddling she could not improve the fonts. She was MOST upset with the new driver. I then noted that both VLC and Media Player Home Classic no longer would play the AVCHD high definition videos, … ie the new ATI winXP driver did not support Windows AVIVO like it was supposed to, on this Laptop’s Radeon HD 3450. At that point I became most upset with the new driver.

To make a long story story, yesterday (27-Dec) I rolled back to the older 8.x ATI graphic driver for winXP on this Laptop and all was well again, except the occasional crashes were still happening. (latest view - maybe it is the Bluetooth driver causing this crash on winXP).

But easy? … not for us. You should have heard me cursing about Windoze drivers, and my wife for once agreeing with my assessment.

What instructions?! See that’s the thing - there were NO instructions from NVIDIA for linux (let alone openSUSE) AND when I called tech support, they had no linux techs working (they only have two in the whole office) so they couldn’t help me.

6tr6tr there are instructions. I can’t explain why nVidia can not help you, but there are instructions and there are many volunteers on our forum, in the IRC chat channel #suse (on freenode) and also in the mailing lists.

I did a 30 second search on google and came up with

It took me about 20x as long to type the above.

When you say “NO instructions for linux” I honestly do not believe you looked. Apologies. I just don’t believe.

(1) A simple search for nvidia at the can bring up the help link.
(2) Also, nvidia site provides fairly detailed information about the Linux drivers too.

I meant in the box.

And the instructions on were a little confusing. It says that you only install this new driver for NVidia GeForce 6 or later. Mine is an 8400 gs, so clearly the numbers mean different things. So it actually took quite some searching to determine mine fit into that category and that was the driver I wanted.

ahh … ok… then IMHO thats a good reason to call ATI and shake their tree a bit. >:)

Have a look at my ‘canned’ response for doing it the hard way here
(post #2);

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 15:26, 3 users, load average: 0.39, 0.18, 0.05
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

oldcpu wrote:
> palladium;2094479 Wrote:
>> even with ‘easy’ Redmond software
> … easy … hmmm… EASY ?
> But easy? … not for us.

there was a reason i put ‘easy’ inside single quote marks…it was not
me saying it was it easy…i was just quoting the masses who come
here and complain about Linux being hard and praise Redmond’s being so

and THEN change a video card and expect it to work automatically
when we all know it is not automatic in the “easy” system either…


i need help! in the system information is still says driver unknown… can someone please help.

hwinfo --gfxcard

25: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_10de_422
Unique ID: VCu0.88gJLUEux88
Parent ID: vSkL.KeIzu5mXpD3
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “nVidia GeForce 8400 GS”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0422 “GeForce 8400 GS”
SubVendor: pci 0x1682 “XFX Pine Group Inc.”
SubDevice: pci 0x2309
Revision: 0xa1
Driver: “nvidia”
Driver Modules: “nvidia”
Memory Range: 0xfd000000-0xfdffffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (rw,prefetchable)
Memory Range: 0xfa000000-0xfbffffff (rw,non-prefetchable)
I/O Ports: 0xcc00-0xcc7f (rw)
Memory Range: 0xfe9e0000-0xfe9fffff (ro,prefetchable,disabled)
IRQ: 16 (10929 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd00000422sv00001682sd00002309bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: nv
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #11 (PCI bridge)

Primary display adapter: #25

Your nVidia 8400GS is recognized.

May I suggest you read this practical graphical theory guide to obtain a bitter perspective of the graphical drivers available: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

SaX: initializing please wait…
SaX: your current configuration will not be read in

SaX: access to your display has been granted
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
Xlib: extension “XFree86-Misc” missing on display “:0.0”.
SPP: prepare device [0] profile: nobus
SPP: including prepared profile(s)…

SaX: startup
SaX: X-Server: :0.0 → grant
SaX: using cache data…

I read the article and followed the instructions… when i run
sax2 -r -m 0=nv or sax2 -r -m 1=nv I get this error message.

X Error: XsynBadAlarm 116
Extencion: 164 (unknown Extension)
Minor upclode:11 (unknown Request)

it repeats that error several times.

Why are you running sax2 -r -m 1=nv ?

Do you have two graphic card devices?

The article notes you should 1st run ‘sax2 -p’ to see if you graphic card is chip 0 or chip 1. Did you do that? If you did that you would know which chip and you would not need to run both “sax2 -r -m 0=nv” and “sax2 -r -m 1=nv”. I’m thinking you did not understand the article, or I am thinking that I messed up writing the article because it was not understood.

What is the output (run with root permissions) of:

sax2 -p

If this is integrated graphics on the motherboard, is it switched ON in the BIOS ?

What is the output (run with regular user permissions) of:

rpm -qa '*driver*'

Did you also try the vesa and the fbdev driver?

I too must be having problems with my graphic card. I’m new to SuSE(linux period), and am just getting the hang of things. My highest screen resolution is lower than it supposed to be, and I cant enable some of the desktop effects, such as the cube. I ran sax2 -p and got this:

Chip: 0 is -> NVidia GeForce 8400M GT 01:00:0 0x10de 0x0426 AGP nv

I then ran in normal user mode-rpm -qa ‘driver’, and got this:


Any help would be greatly appreciated.

The rpm xorg-x11-driver-video-7.4-87.90.1.x86_64 contains the “nv” driver (and also the “vesa” and “fbdev” slower drivers).

I put some guidance here:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

In your case, the command from run level 3 (run with root permissions), if you wish to create an /etc/X11/xorg.conf file will likely be

sax2 -r -m 0=nv

… and custom select your graphics. ie you can reject the proposed configuration and you will then under sax2 be given an option to tune the graphics.

… but its also possible you could just delete any /etc/X11/xorg.conf file and the xorg autoconfig of your graphics will work.