Cannot enable autologin

In plasma 5 I selected ‘autologin’ in System Settings > Startup and Shutdown. After reboot I still have to enter my password to log in. Initially the /etc/sddm.conf file has my user name there, after reboot the user name is missing and the ‘autologin’ option in System Settings is reset to disabled. Also in Gnome the autologin switch is permanently in the off position, can’t click it to the ‘on’ position.

Where can I look to see what might be interfering?

If KDE Configure Desktop login


Yast - /etc/sconfig editor - desktop -Display Manger - DISPLAYMANAGER-AUTOLOGIN.

set the user to blank

To enable autologin, you have to insert a valid User Account name, not blank.
That way, the machine will automatically login to that User Account when the Desktop loads.


That did it. Thanks!