Cannot Edit Power Saving Settings in Battery Monitor

Hi all,

I got a strange problem. I can get to the battery monitor but there are no options to set the power management behavior when on AC or on battery. The tabs (Ac, Battery and Low Battery) are blank.

Syetem: openSUSE 12.3 64 bit
HP Probook 4530s
Battery works fine.

I want to change the sleep duration because it’s sleeping every few minutes (Again, I cant tell I cant view the settings)

Is there a command line option to set these parameters?

On 05/26/2013 10:46 AM, lawi wrote:
> Hi all,
> I got a strange problem. I can get to the battery monitor …
> Is there a command line option to set these parameters?

the “battery monitor” is not the place to set power savings
function…and i have no idea where/how the command line could be
useful here…

but, while i can’t tell you where it is in all desktop environments
on openSUSE (and since you didn’t say which desktop environment you
use) i’ll give KDE instructions and hope that helps you:

in the menu go Configure Desktop - Personal Settings > Hardware >
Power Management and use the “Help” button to select and setup the
global, power profiles and advanced battery settings as you wish…


Hi DeverD,

My bad. I should have indicated the desktop env. And yes, it’s KDE.

Thank you so much for the instructions. It sorted me.

I am coming from Kubuntu and I usually set the power options by right clicking on the tray icon and getting to the settings from there.

I still dont see the point of putting blank tabs. Just saying :slight_smile:

Still, thank you very much

On 05/26/2013 01:26 PM, lawi wrote:
> I still dont see the point of putting blank tabs
> The tabs (Ac, Battery and Low Battery) are blank…

you are welcome.

and, sorry i failed to notice the first time how new you are here,
let me say:

-=WELCOME=- new poster!!

i agree there is no sense in making blank tabs…i wonder how that
happened on your machine…on mine, my KDE battery monitor has no
blank tabs when i left click the icon, i see:

Battery: 100% Charged		or xx% (discharging)
AC Adepter: Plugged in		or Not plugged in
Time remaining: [blank]  	or X hours XX minutes
Power Profile: Performance	or Powersave
Screen Brightness: (slider max)	or slider about 2/3

when i right click to settings, on the left i have three choices:
General, Keyboard Shortcut and Share…selecting any of those three
and everything works, not a blank anything in sight!

SO, i wonder why yours is different…i wonder when you moved from
Kubuntu did you keep your /home, which had all of your desktop
configs in it? maybe one of those is not compatible with the KDE in

or maybe it is because you and i are using different versions of KDE,
(i can’t tell since you didn’t say yours…mine is KDE 4.6.0-6.17.1)

or maybe it is because your hardware doesn’t provide the information
needed in the way the battery monitor expects it. so, i wonder if you
have you installed the package named ‘sensors’ (mine is version

or have you installed:

patterns-openSUSE-laptop (mine: 11.4-6.9.1)
patterns-openSUSE-kde4_laptop (mine: 11.4-6.9.1)
laptop-mode-tools (mine 1.53-8.1)

if you want to try any of those you should use the version in the oss
repo…if you don’t know how to do that (we have no “apt get” but
something similar) ask (or read on below)

anyway, trying to do stuff the way you did (like set power savings
functions or install software) in Kbuntu may or may not be the way
you have to do things in openSUSE…so, keep asking! on the other
hand there are probably some very helpful info in these:


I installed the same opensuse 12.3 kde live on another machine and true enough, the options were there on the tabs. I ran the live usb on my laptop and again, the tabs were available.

So in the the true spirit of a lazy person (and since it was a fresh install anyway) I reinstalled the OS, completely deleting the previous instance and now I have the options. Both by right clicking the battery tray icon and going the settings → power management route (which is expected, its the same applet anyway being called from different places)

then i guess it was probably it was a mangled config in your /home…

for future reference:

  1. which could have been more easily and quickly (than reinstalling)
    proven by using YaST to create a new user, then log out and back in
    as the new user…

if it works ok with the new user it is assured something wrong in the
original user’s home, and there might be a faster way to a full fix
by renaming a config or three, and letting the system create a new,
default config.

in other words: reinstalling to fix problems is a technique taught
and supported by a software company in Washington state–it is not
usually the best way or fastest way to fix a stable, reliable,
predictable system. (otoh, reinstalling is a great way to ‘fix’ a
system known to get out of whack just from running)

  1. when moving from one Linux distro to another it is good to think
    of each distro as a completely new and different operating system.
    so, we know it is not completely different, but there are LOTs of
    things in the old they may cause pain in the new and my experience is
    it is best to not drag old configs into the new distro. (dragging
    in old DATA is another matter…that is most often safe and easy…)