Cannot Disable Welcome Screen That Appears after login


I’m have a minor issue. Recently I upgraded my desktop from 15.2 to 15.3. All went well. However, when I logged in for the first time a small “Welcome” screen popped up. The contents was a green screen with a white opensuse logo (afraid to say chamelion or gecko, because I don’t know which it is XD) and it stays that way until I close the window. When I have to log out or restart and then log back in, the welcome screen pops up again.

Does anyone know how to disable it?



On the right side on the bottom line of the welcome screen, you can uncheck “Show on next startup”.

Like I said… its stuck on the green screen. No check box visible :frowning:

Can you make a photo and post it on
On the right side, you can switch to image.

You have not mentioned which desktop environment you are using.

If it happens to be KDE:

System Settings → Startup and Shutdown → Autostart

Next, click “Add Program” near the bottom of the screen.

That should give you a menu to find the program. Select “System → Welcome”.

This adds “Welcome” as an autostart program. Do what additional clicks are needed to complete that.

Then uncheck the box for that autostart program. That should disable it.

(I just tested this procedure, and it seems to work).

It is KDE and thanks nrickert. I will be away from that particular computer for a couple of days. So when I get back to it I will try your suggestion and let you know.

Correct – and, it has neither buttons nor check boxes …

  • But, it should disappear and a “Welcome
    ” window with buttons and a single check box should appear …

This thing also starts if you search for “welcome” in your GUI Starter …
[HR][/HR]Analysis –

  • It’s ‘/usr/bin/opensuse-welcome
    ’ – which is provided by the “opensuse-welcome” package. - The “opensuse-welcome
    ” package is recommended by the “patterns-base-x11_enhanced” pattern.

Please try –

  • Rebuilding the RPM database – “rpm --rebuilddb”.
  • Checking the package dependencies – “zypper verify”.
  • Checking the RPM package contents – “rpm --verify --all” – “rpm --verify opensuse-welcome
    ” may well indicate something but, checking all installed packages won’t hurt. - Forcibly re-install “opensuse-welcome
    ” – “zypper install --force opensuse-welcome”.

Thank dcurtisfra.

I followed your suggestion with one better, by also install opensuse-welcome-lang, but the welcome screen still stayed stuck on the green screen.

I just ran:

zypper remove opensuse-welcome opensuse-welcome-lang

Since no other dependancies were flagged, I believe that will solve my issue.

Thanks everyone :slight_smile:

Please be aware that, because “patterns-base-x11_enhanced” «suggests» “opensuse-welcome”, there are some situations where YaST will auto-magically re-install the “Welcome” application …

  • If you don’t want this to happen, you’ll have to invoke Zypper’s “Package Locks Management
    ” to lock the Welcome package and prevent the re-installation …

If it is in /home/user/.config/autostart
you can simply delete or rename it.

It is actually in “/usr/share/applications/org.opensuse.opensuse_welcome.desktop”

To disable, you need to copy to “/home/user/.config/autostart” and then modify it to disable. That’s what should happen with my suggestion in an earlier post in this thread (post #5).

Thanks for the correction, yes it’s a bit different in Xfce I guess.
I went to my .config and it is set to hidden=true.

Yes. The file is $HOME/.config/autostart is given precedence. So that overrides the desktop file in “/usr/share/applications/”. And that “hidden=true” is what disables it from starting on your next login.

Hi everybody, I just solved this issue by opening yast, software management and choosing “welcome” to be deleted, problem solved, no more annoying green “welcome” screen, hope this helps!

Thanks for the heads up dcurtisfra**.** Both packages are now “taboo” xD

Yes, Neil’s answer is the correct one.

In Xfce, it is in the Settings=>Sessions and Startup

Well I know, I am just relating the difference between plasma and xfce, but the .desktop files are
both in /user_home/.config/autostart/ for plasma and xfce.

Same issue here using Tumbleweed and no matter the last upgrades the green screen lasts until I remove the package. There’s no autostart for that. For curiosity, I reinstall it after a reboot and the issue was back. For now, since this package doesn’t matter anyway, I just let it deleted.


Just an FYI here, since I finally found an answer that works. Well, the answer given in post #5 was correct, although not complete.

        Originally Posted by **nrickert**           ](                 
             It is actually in "/usr/share/applications/org.opensuse.opensuse_welcome.desktop"

To disable, you need to copy to “/home/user/.config/autostart” and then modify it to disable. That’s what should happen with my suggestion in an earlier post in this thread (post #5).

After copying to /home/user/.config/autostart I added the line “NotShowIn=KDE” in order to disable the green welcome screen. “NoDisplay=true” and “hidden=true” did not work. (BTW, I’m sure replacing KDE with Gnome or XFCE or MATE will do the same thing.)

I spent time looking for the boolean that would be changed when one checked the “Do not show again” box in a working opensuse-welcome window to no avail. What happens when you check that box? I’d love to know.

Thanks again to nrickert :slight_smile: