Cannot Disable Touchpad KDE4 HP Pavillion

Hello all,

I absolutely hate laptop touchpads and for the life of me cannot disable mine under OpenSuse v11 KDE4 (or Gnome)! It is unbelievably annoying for me. It continually interferes when I’m typing, etc. I’ve tried all of the normal edits to xorg.conf, but no change. I’ve commented out the touchpad section completely in xorg, but again, no change.

Also, even though “Option SHMConfig on” is correctly entered into xorg.conf, I keep receiving error messages that it is not active when trying to execute commands to turn off the touchpad.

After commenting-out the touchpad in xorg.conf, it removes the touchpad entry in “SaX2-Hardware-Mouse Models”, but the touchpad keeps right on working!

Can someone PLEASE help me with this?!?! Thanks!

Don’t remove the stuff in XORG.

To totally disable it (if you have alternate mouse), simply issue cmd:
synclient TouchpadOff=1
in console each time you login.

If you need more dynamic interaction, full (Ubuntu) doc info here:

I’ve tried that, but keep getting an error:

“Can’t access shared memory area. SHMConfig disabled?”

The SHMConfig option is correctly entered in xorg.conf and turned on.

Any ideas why SHMConfig appears to not be active even if it’s properly set in xorg?

I have completely removed all mouse references from xorg.conf and the stupid touchpad STILL works. Is there another driver or config file in openSUSE v11 that can control the mice and override the xorg settings? I’d even consider completely uninstalling all the drivers for the touchpad in Suse because I never use it. I prefer using a wireless mouse.

Please… any and all help would being honestly appreciated!


As I mentioned before, do NOT try to remove the touchpad
from xorg.conf.

Does this help?:
Nabble - Linux Thinkpad - Thinkpad utilities query

Also, some have been able to disable touchpad in bios.

[Google is your friend.]

I’ve tried it with and without, I now have it back to the initial settings and no matter what I’ve tried, the touchpad continues to work (get in the way) and I always get the above error message for SHMConfig.

There has to be “something” else controlling this touchpad and it must be interfering with the other services. Is there a way to list ALL of the active mouse drivers and config services that are loaded? Is there another system configuration file that would deal with loading mouse drivers besides xorg?

Hey, i’m having the opposite problem-mine wont work, just click and right click.

Synaptic Mouse on Laptop - openSUSE Forums

Someone, please help! I need to be able to use the built in mouse for on the go-in college-schoolwork

You two should just trade laptops! lol!

foresthill - funny.

Hawk5471 - I have the same problem. I can’t disable the touchpad, via comand line or through any GUI.

And sadly so far, none of the “replies” here posted would I consider helpful.

Can anyone give us a useful solution please?

You can try to disable the touchpad in the BIOS system, most likely you find your answer there.(worked for my Lenovo laptop)

Install gsynaptics rpm from the standard repos. It’s a Gnome tool. But it works fine in KDE too and seems to be independent of the Desktop Environment. It works for me including “tapping” on off. There’s also a standard RPM called “touchfreeze” for disabling tap-to-click

Hi! Disable Touchpad I have an Acer TravelMate 7720G and first i tried with Touchfreeze but unfortunately with but it did not work for me… So before i found this thread I searched in RPM and found gsynaptics… I am using Suse 11.2 KDE version and everything works out excellent since i have installed all optionals for restricted formats for Suse 11.2 Restricted Formats - openSUSE-Community

Best regards
Jan lol!