Cannot create shortcut in KDE


I’m experiencing some strange behavior when trying to create a specific shortcut:
I want to assign the action “Window One Desktop to the Right” of the KWin component to the shortcut Meta+Ctrl+Shift+Right.
However, I can’t. When I try to enter the shortcut, pressing the right-key in the end is just ignored. Setting all other directions analogously worked just fine.

Does anyone experience the same behavior?

I’m using openSUSE 12.3 (x86_64) with KDE 4.10.3 “release 1”.

By the way, I tried to enter the shortcut manually in ~/.kde4/share/config/kglobalshortcutsrc. Now it’s listed correctly in the system settings, but the shortcut is not working.

Thanks in advance!

Hm, no ideas at all?

Can someone check if they are able to create the shortcut or if they have the same behavior?
So I’d know if the problem is in my system or if it’s a KDE issue.

Thank you

No answers here too

Hmm, too bad.
In the meantime I installed openSUSE with KDE (same version) on another machine. I was able to set the shortcut there, so I must be my machine.
I tried to rename the folder ~/.kde4/share/config, so I got a new one with all shortcuts reset to default values. However, I was still unable to create the shortcut…

Strange. Rebooted after a crash on KDE and not I can place shortcuts everywhere on the desktop.