Cannot connect usb devices to Virtualbox guest

I have followed directions from many places including here and here, but Virtualbox keep showing “No devices available” in the guest OS settings. The Guest OS is Windows 8.1. Any help would be appreciated.

USB support is disabled by default in openSUSE’s virtualbox packages because of security concerns.

To enable it, create a file /etc/udev/rules.d/60-vboxdrv.rules (on the openSUSE host) with the following content:

KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

Running “sudo /etc/init.d/vboxdrv setup” should do that automatically, but I’m not sure at the moment if that recent change is in 42.1 already too.

Afterwards you need to reboot the host (or run “sudo udevadm control reload”) for the change to have effect.

I’ve created the file but there seems to be no notable difference. Furthermore, sudo

udevadm control reload

returns

Extraneous argument: reload


Sorry, it should have been “udevadm control --reload”.

Or just reboot, as I wrote.

I have rebooted a couple of times but there is no notable difference yet.

Are you using USB 3.0?

If yes, maybe the guest OS needs USB-3-0-Driver-Intel-USB-3-0-eXtensible-Host-Controller-Driver from Intel to support this. Please refer to https://forums.virtualbox.org/viewtopic.php?f=7&t=68938#p328407 for further information if suitable.

Yes, the first question before anything else should have been to identify whether Virtualbox was installed from the OSS or from the Oracle website.

After that, regardless where it was installed from you should download and install the Extension Pack from the following web page
https://www.virtualbox.org/wiki/Downloads

TSU

My Virtualbox, i believe, is from the OSS. The version number is

VirtualBox Graphical User Interface Version 5.0.26_SUSE r108824

Even USB 2.0 does not function

Apparently, “there is no update candidate for virtualbox”.

Is there a way I can remove this OSS version and install the one from Oracle website without messing with package dependencies?

Go to yast and remove it

You need to install the extension pack for USB 2.0 support.
And that’s the same regardless whether you install openSUSE’s or Oracle’s VirtualBox.
The two should be basically the same anyway, except for differences in the packaging.

Also, I hope you are aware that the guest will not automatically see any USB devices.
You have to “enable” them first, in the VM’s menu (“Devices”).

To the OP:
Recommend you stay with your current Virtualbox installation and install the Extension pack (plus make the other edits wolfi described).

If you decide later to change to the Virtualbox from Oracle’s website, you can do so at any time without losing the virtual machine Guests you’ve created.

If that time comes where you want to change Virtualbox sources, you can post again with any issues you might run into.

IMO,
TSU