Cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter

I cannot connect to wifi with openSUSE on a Rosewill RNX-AC600NUBv2 USB adapter. It is plug and play with Windows 10. It works on one machine with Mint 19.3 and the driver recommended at https://forums.linuxmint.com/viewtopic.php?p=1757446#p1757446.

On this openSUSE machine (Leap 15.2 KDE) I installed rtl8812AU_8821AU-kmp-default from https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.2_Update/

When trying to connect to either our home network or the building wifi, I get two successive pop-up windows asking for the password, then a failure stating “No secrets were provided”
I get:

howard@HP-oS15KDE:~> lsusb
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 0bda:a811 Realtek Semiconductor Corp. RTL8811AU 802.11a/b/g/n/ac WLAN Adapter
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and

howard@HP-oS15KDE:~> sudo iwconfig; dmesg | grep wlx
[sudo] password for root: 
lo        no wireless extensions.

eth0      no wireless extensions.

tun0      no wireless extensions.

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.432 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

howard@HP-oS15KDE:~>

and

howard@HP-oS15KDE:~> inxi -Nn
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 1c:1b:0d:ab:25:f5 
           Device-2: Realtek RTL8811AU 802.11a/b/g/n/ac WLAN Adapter type: USB driver: rtl8812au 
           IF: wlan0 state: down mac: 00:e0:4c:43:24:d9 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
howard@HP-oS15KDE:~>

and

howard@HP-oS15KDE:~> sudo rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
howard@HP-oS15KDE:~> 

Our router uses MAC address filtering, and this device is correctly allowed as shown by the Win10 and Mint connections.
/etc/NetworkManager/NetworkManager.conf now contains

 [device]
 wifi.scan-rand-mac-address=no

in case that is still lurking in openSUSE.

What needs to be done to get this connected with openSUSE?

Thanks,

Post:

zypper se -si rtl88
ip a
howard@HP-oS15KDE:~> zypper se -si rtl88
Loading repository data...
Reading installed packages...

S  | Name                         | Type    | Version                             | Arch   | Repository
---+------------------------------+---------+-------------------------------------+--------+-----------
i+ | rtl8812AU_8821AU-kmp-default | package | 20200719_k5.3.18_lp152.26-lp152.2.1 | x86_64 | Sauerland
howard@HP-oS15KDE:~>

and

howard@HP-oS15KDE:~> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 1c:1b:0d:ab:25:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.145/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
       valid_lft 86116sec preferred_lft 86116sec
    inet6 fe80::c873:5362:458f:178f/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:e0:4c:43:24:d9 brd ff:ff:ff:ff:ff:ff
5: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
    link/none 
    inet 184.23.191.89/25 brd 184.23.191.127 scope global noprefixroute tun0
       valid_lft forever preferred_lft forever
    inet6 fe80::4428:bad1:4e9c:9cbb/64 scope link stable-privacy 
       valid_lft forever preferred_lft forever
howard@HP-oS15KDE:~> 

Hi
I suspect it’s not built for the updated kernel, you need to be using this repo;

https://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.2_Update/

Also you have to disable secure boot in the Bios/UEFI.

I deleted version 20200719_k5.3.18_lp152.26-lp152.2.1, changed to the above repo, and installed the rtl8812AU_8821AU-kmp-default there. Now I get

howard@HP-oS15KDE:~> zypper se -si rtl88
Loading repository data...
Reading installed packages...

S  | Name                         | Type    | Version                             | Arch   | Repository
---+------------------------------+---------+-------------------------------------+--------+-----------------
i+ | rtl8812AU_8821AU-kmp-default | package | 20200719_k5.3.18_lp152.33-lp152.1.2 | x86_64 | Sauerland update
howard@HP-oS15KDE:~>

and

howard@HP-oS15KDE:~> ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 1c:1b:0d:ab:25:f5 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.145/24 brd 192.168.1.255 scope global dynamic noprefixroute eth0
       valid_lft 86031sec preferred_lft 86031sec
    inet6 fe80::c873:5362:458f:178f/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:e0:4c:43:24:d9 brd ff:ff:ff:ff:ff:ff
4: tun0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100
    link/none 
    inet 184.23.190.239/25 brd 184.23.190.255 scope global noprefixroute tun0
       valid_lft forever preferred_lft forever
    inet6 fe80::e47e:b833:69ae:239b/64 scope link stable-privacy 
       valid_lft forever preferred_lft forever
howard@HP-oS15KDE:~>

and

howard@HP-oS15KDE:~> uname -a
Linux HP-oS15KDE 5.3.18-lp152.33-default #1 SMP Wed Jul 22 06:32:33 UTC 2020 (e5a8383) x86_64 x86_64 x86_64 GNU/Linux
howard@HP-oS15KDE:~>

but still no connection. Again, when trying to connect to either our home network or the building wifi, I get two successive pop-up windows asking for the password, then a failure stating “No secrets were provided”
Thanks,

This old motherboard does not speak UEFI.
Regards,

Please post as root:

systemctl status network.service

And try it without Lan-connection…

HP-oS15KDE:/home/howard # systemctl status network.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Mon 2020-07-27 09:00:27 PDT; 44min ago
     Docs: man:NetworkManager(8)
 Main PID: 1195 (NetworkManager)
    Tasks: 7
   CGroup: /system.slice/NetworkManager.service
           ├─1195 /usr/sbin/NetworkManager --no-daemon
           ├─3585 /usr/lib/nm-openvpn-service --bus-name org.freedesktop.NetworkManager.openvpn.Connection_11
           └─3588 /usr/sbin/openvpn --remote ovpn.sonic.net 1194 udp --comp-lzo yes --nobind --dev tun --cipher AES-128-CBC --auth-nocache --tls-auth /home/howard/.local/share/ne>

Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866260.6574] device (wlan0): Activation: (wifi) association took too long
Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <info>  [1595866260.6575] device (wlan0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866260.6602] device (wlan0): Activation: (wifi) asking for new secrets
Jul 27 09:11:00 HP-oS15KDE NetworkManager[1195]: <info>  [1595866260.7261] audit: op="statistics" arg="refresh-rate-ms" pid=2845 uid=1000 result="success"
Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866262.7153] device (wlan0): no secrets: User canceled the secrets request.
Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <info>  [1595866262.7153] device (wlan0): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <warn>  [1595866262.7191] device (wlan0): Activation: failed for connection 'SFTInternet'
Jul 27 09:11:02 HP-oS15KDE NetworkManager[1195]: <info>  [1595866262.7198] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Jul 27 09:11:06 HP-oS15KDE NetworkManager[1195]: <info>  [1595866266.8667] device (wlan0): supplicant interface state: disconnected -> inactive
Jul 27 09:11:06 HP-oS15KDE NetworkManager[1195]: <info>  [1595866266.8670] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> inactive

HP-oS15KDE:/home/howard #

I had tried wifi after disconnecting lan in NM. This time I unplugged the cable and get

HP-oS15KDE:/home/howard # systemctl status network.service
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Mon 2020-07-27 09:00:27 PDT; 50min ago
     Docs: man:NetworkManager(8)
 Main PID: 1195 (NetworkManager)
    Tasks: 4
   CGroup: /system.slice/NetworkManager.service
           └─1195 /usr/sbin/NetworkManager --no-daemon

Jul 27 09:50:34 HP-oS15KDE NetworkManager[1195]: <info>  [1595868634.8405] device (p2p-dev-wlan0): supplicant management interface state: scanning -> associating
Jul 27 09:50:36 HP-oS15KDE NetworkManager[1195]: <info>  [1595868636.4794] device (wlan0): supplicant interface state: associating -> disconnected
Jul 27 09:50:36 HP-oS15KDE NetworkManager[1195]: <info>  [1595868636.4796] device (p2p-dev-wlan0): supplicant management interface state: associating -> disconnected
Jul 27 09:50:40 HP-oS15KDE NetworkManager[1195]: <warn>  [1595868640.6574] device (wlan0): Activation: (wifi) association took too long
Jul 27 09:50:40 HP-oS15KDE NetworkManager[1195]: <info>  [1595868640.6575] device (wlan0): state change: config -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Jul 27 09:50:40 HP-oS15KDE NetworkManager[1195]: <info>  [1595868640.6587] manager: NetworkManager state is now DISCONNECTED
Jul 27 09:50:40 HP-oS15KDE NetworkManager[1195]: <warn>  [1595868640.6619] device (wlan0): Activation: failed for connection 'howardcathy_GN2.4'
Jul 27 09:50:40 HP-oS15KDE NetworkManager[1195]: <info>  [1595868640.6623] device (wlan0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Jul 27 09:50:46 HP-oS15KDE NetworkManager[1195]: <info>  [1595868646.4847] device (wlan0): supplicant interface state: disconnected -> inactive
Jul 27 09:50:46 HP-oS15KDE NetworkManager[1195]: <info>  [1595868646.4851] device (p2p-dev-wlan0): supplicant management interface state: disconnected -> inactive
HP-oS15KDE:/home/howard # 

Regards,

Post:

ls -al /etc/NetworkManager/system-connections/

This is with the wifi adapter and cable plugged in, and the wired connection active.

howard@HP-oS15KDE:~> ls -al /etc/NetworkManager/system-connections/
total 48
drwxr-xr-x 2 root root 4096 Jul 26 18:30 .
drwxr-xr-x 5 root root 4096 Jul 26 08:32 ..
-rw------- 1 root root  414 Jul 26 18:30 howardcathy_AN5.nmconnection
-rw------- 1 root root  309 Jul 26 08:57 howardcathy_GN2.4-b757c7df-6c82-4ad0-94eb-afbd8880350c.nmconnection
-rw------- 1 root root  414 Jul 26 18:30 howardcathy_GN2.4.nmconnection
-rw------- 1 root root  626 Sep 23  2019 PIA California
-rw------- 1 root root  614 Aug 27  2018 PIA Switzerland
-rw------- 1 root root  614 Feb  3  2019 PIA UK London
-rw------- 1 root root  356 Jul 25 18:40 SFTInternet5.nmconnection
-rw------- 1 root root  357 Jul 25 18:48 SFTInternet.nmconnection
-rw------- 1 root root  869 May 22 15:08 Sonic
-rw------- 1 root root  451 Jul 12 11:31 Wired connection 1
howard@HP-oS15KDE:~> 

Does it work if you use a static IP in the Networkmanager?

I’m not sure how to do that. Do you mean for a connection entry, setting an IPv4 route?
Thanks,

I set an IPv4 route to 192.168.1.125, which was unused in the router. That had no effect - still no connection.
Regards,

I don’t know if “no secrets” means the same as “no secrets that can be deciphered.”

  1. From your first post,
    I interpret your log to mean that your system is successful initiating the connection to your WiFi AP but is unable to negotiate a preliminary network connection but is unable to submit your WiFi password. The error suggests that your WiFi password is simply missing although I won’t completely eliminate an encryption problem. This should eliminate most hardware problems but maybe not entirely the NIC driver.

  2. Are you setting up a system connection on boot or a manually invoked connection by the User?

  3. From the machine name in your logs, I assume you’ve installed and are running KDE/Plasma. Are you storing your credentials in kwallet, and encrypted or plain text? For that matter, you can alter any combination of these settings for troubleshooting purposes (including connect on boot or invoked by the User).

TSU

The entire message is “No secrets were provided”

  1. From your first post, I interpret your log to mean that your system is successful initiating the connection to your WiFi AP but is unable to negotiate a preliminary network connection but is unable to submit your WiFi password. The error suggests that your WiFi password is simply missing although I won’t completely eliminate an encryption problem. This should eliminate most hardware problems but maybe not entirely the NIC driver.
    NetworkManager shows the APs as available, and after clicking one, two successive windows appear asking for password, then the failure to connect and notice “No secrets were provided”
  1. Are you setting up a system connection on boot or a manually invoked connection by the User?
    I start these manually in NM, not at boot.
  1. From the machine name in your logs, I assume you’ve installed and are running KDE/Plasma. Are you storing your credentials in kwallet, and encrypted or plain text? For that matter, you can alter any combination of these settings for troubleshooting purposes (including connect on boot or invoked by the User).
    Yes, this is KDE/Plasma. NM stores the passwords encrypted for a single user. I have tried many settings of firewall on and off, router security enabled and disabled. Nothing works in openSUSE, only in Mint.
    Regards,

You have to answer 2 password winows?

So maybe the first is from kwallet and the second is from the Wlan.

Yes, after a pause, one window appears,https://previews.dropbox.com/p/thumb/AA2YgN8Ej9TNkVx5JOVixJ7Z3QN7BHRlI8-SxRzMce6vlZBBMXokvI-1-EcmwaqiVRsGo6NxtvD4vwCRkGsXuupttioFM_ByoUKeXwciTmdkiuVvC-zJJGndf6LAysVPZTvrQV01pem8hI8DHiSAtmmBbQ1wTdyS0bQfeNNnR7Wv8JzHX0kuEi-0aN5UYA08hM6Ix1ZmQjN8Is-nYx_VDUEK7MmdDM3UtOnlFQnVzHm-eEsGKaYr9WMMYjM0VPgvD1pX-hefvTfAca8bn4Fp8Bj8-dlF2xHJfhAsbFIywfysZkRVjFAteyNXqspchTxARNJjoAqwYmjHoH7xUspRdtwQ/p.png?size=100x100&size_mode=10 then after typing the password and another pause, the second identical window appearshttps://previews.dropbox.com/p/thumb/AA1-NchH5XTO2Y-yDJabcXFiG8nF8aB1G91jX3HfwALR6f5TL7zIrLyagmOeFul8bhRLmhDKJSNZct0xqXtp3Gxhpyr0esAmdeB80LHDw0qkca5E8OPOifX8KFFIQk_w6XyquiPBBhl-u5gVRRwaO0kzRTAAnTBcpR7V8EGSR0ONXkiBUMwwrgZiJySROta7KcG4CQsZLrM8IzjNQ7kvhsrNwUFPUbxxSpGBccO3FBMQQsnpEpTm_D7PGHCtOQCDVeT54-c7V1Mxb7NOa_tRN7rK/p.png?size=256x256&size_mode=2, and after giving the password again, then the failure notice.