Cannot connect to wifi in Opensuse 42.1 Gnome

I just installed the Opensuse 42.1 with gnome user interface. and I don’t see any wifi logo in top right of screen.
As written in documentation, running sudo hwinfo --wlan --short results empty. In alternative running lsusb shows:
http://i66.tinypic.com/14o7iar.jpg

In Yast -> Hardware Information, I can see my Network Card-> BCM4312 802.11b/g LP-PHY and in Driver section of same page, Active=yes.
so knowing my driver, I installed the driver with sudo install_bcm43xx_firmware. but after a restart of system, it still doesn’t work.

Also when I run All settings -> network and click on +, there is no Wifi option.

Apparently this is a built-in wireless card.
Please post the output of “lspci -nnk” then instead.

In Yast -> Hardware Information, I can see my Network Card-> BCM4312 802.11b/g LP-PHY and in Driver section of same page, Active=yes.

If it really is a BCM4312 card, it should be supported out of the box. A driver (b43) is included in the kernel.

so knowing my driver, I installed the driver with sudo install_bcm43xx_firmware. but after a restart of system, it still doesn’t work.

Well, this installs the firmware necessary to operate the card, not the “driver”… :wink:

GNOME’s network stuff only works with NetworkManager though.
So open YaST->System->Network Settings->Global Options, and make sure it is set to “NetworkManager Service” and not “Wicked Service”.
With Wicked, you’d need to configure the connection in YaST.

If that doesn’t help either, try to install the proprietary broadcom-wl driver from Packman.
You need the packages broadcom-wl and broadcom-wl-kmp-default.

thanks for reply:)

here is the output of **lspci -nnk

http://www18.online-convert.com/download-file/d6bf1348e99865c60844b74bc8edd0bc/converted-4328245b.jpghttp://www5.online-convert.com/download-file/17d5cb26e78dcd6c2ddedb9be8fb1c41/converted-eeae6759.jpg
**
Also “NetworkManager Service” is already selected in YaST->System->Network Settings->Global Options.

About the packages broadcom-wl and broadcom-wl-kmp-default, how can I install them offline? There is no connection on machine with opensuse. Maybe there is a way to transfer them with usb flash memory.

Cheers

Ok, so it is indeed a BCM4312, PCI id 14e4:4315.
This should be supported by the b43 driver according to https://wireless.wiki.kernel.org/en/users/drivers/b43

Did “sudo install_bcm43xx_firmware” report an error? AFAIK it downloads the firmware from the Internet, so wouldn’t work without an Internet connection (which you say you don’t have).

There’s this sticky post in the “Wireless” subforum though:
https://forums.opensuse.org/showthread.php/484106-Broadcom-firmware-is-needed-for-b43-but-I-have-no-network-an-easierwork-around

This should make it work.

Also “NetworkManager Service” is already selected in YaST->System->Network Settings->Global Options.

Good.

About the packages broadcom-wl and broadcom-wl-kmp-default, how can I install them offline? There is no connection on machine with opensuse. Maybe there is a way to transfer them with usb flash memory.

You can download them here:
http://packman.links2linux.de/package/broadcom-wl
(be sure to pick the right packages for your distribution)

Then install them with “sudo rpm -i broadcom-wl-xxx.rpm broadcom-wl-kmp-default-xxx.rpm”.

But if the included b43 driver works, it’s probably less hassle to use just that (especially in the case of kernel updates or distribution upgrades).