cannot connect to repositories

When I try to do an online update, I get this error:

message: Couldn’t resolve host 'download.opensuse.org

I have read everything I can find about this issue but can’t resolve it.

All my browsers are fine and connect ok.

I am connected by DSL through a modem to the AT&T network

I have disabled ipv6 in network devices network settings - is there anything else I should do?.

Did you check by typing download.opensuse.org in a browser?

Does

host download.opensuse.org

give an IP address or an error?

Give the output of

zypper lr -d

to chek if you have no typos there.

It’s probably a DNS issue
Most get round it by manually entering their ISP’s DNS info, rather than using the default DHCP

if you don’t know the IPs of the name servers, use Google’s free offering 8.8.8.8 and 8.8.4.4

“host download.opensuse.org” produces


redrider@linux-z60a:~> host download.opensuse.org
download.opensuse.org has address 195.135.221.134

and “zypper lr -d” produces


redrider@linux-z60a:~> zypper lr -d
# | Alias        | Name                  | Enabled | Refresh | Priority | Type | URI                                                             | Service
--+--------------+-----------------------+---------+---------+----------+------+-----------------------------------------------------------------+--------
1 | repo-debug   | openSUSE-11.3-Debug   | Yes     | Yes     |   99     | NONE | http://download.opensuse.org/debug/distribution/11.3/repo/oss/  |        
2 | repo-non-oss | openSUSE-11.3-Non-Oss | Yes     | Yes     |   99     | NONE | http://download.opensuse.org/distribution/11.3/repo/non-oss/    |        
3 | repo-oss     | openSUSE-11.3-Oss     | Yes     | Yes     |   99     | NONE | http://download.opensuse.org/distribution/11.3/repo/oss/        |        
4 | repo-source  | openSUSE-11.3-Source  | Yes     | Yes     |   99     | NONE | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |        
5 | repo-update  | openSUSE-11.3-Update  | Yes     | Yes     |   99     | NONE | http://download.opensuse.org/update/11.3/                       |        
redrider@linux-z60a:~> 

That fixed it

Just in time for the end of the year (or are you allready in 2011?)

Cool.
Well done

Hi,
I’m also having problems connecting; actually my situation is a bit weird. I’ve been trying out openSUSE (11.3 KDE) for the last couple of months and so far like having it as an option alongside my existing Ubuntu install. Everything was working fine (most internet-based things seemed slower than in Ubuntu but they worked) until the last update I did a few days ago. (I couldn’t figure out where to find the install history in YaST but there was a kernel update among some other stuff - I’d been away for a few weeks.)

Anyway, now my situation is this: I can browse the web just fine using Firefox, but nothing else that involves the internet is working: I can’t access repositories, none of my plasma applets that need the internet are working, and I can’t check email in Thunderbird. Aside from applying updates, I made no changes to the settings. I tried using the suggestion in this thread but I still can’t connect to the repos.
Any suggestions?
(Apologies if this is a bit of a thread hijack but this turns out to be a difficult one to search for on Google!)