Cannot connect to internet (but can detect networks) on OpenSuse 12.2

Hi, I just installed opensuse 12.2 64 bit and I am able to view networks but am unable to access internet. These are the outputs of the commands that I run:

~~ sudo /usr/sbin/iwconfig

wlan0 IEEE 802.11bgn ESSID:“Apt6”
Mode:Managed Frequency:2.437 GHz Access Point: 58:6D:8F:5A:8E:FC
Bit Rate=48 Mb/s Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:1FA8-1A3F-A293-5CB7-A370-EE5F-AD
Power Management:off
Link Quality=65/70 Signal level=-45 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:208 Missed beacon:0

~~ ping Google

ping: unknown host Google

~~ sbin/ifconfig

wlan0 Link encap:Ethernet HWaddr C8:3A:35:C9:F2:A4
inet6 addr: fe80::ca3a:35ff:fec9:f2a4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:175 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:57198 (55.8 Kb)

Also, I don’t have the wireless icon in the lower right hand corner of my desktop (toolbar). Anybody know how I can get this? Thanks in advance

KDE or Gnome?

In Yast > Network Devices > Network Settings

Is it set to Network Manager Controlled ? or ifup?
Use Network Manager.

In kde the network manager control for the desktop can be added, from the widget list

Might be an idea to see the result of
/sbin/lspci -nnk | grep -iA2 net

Thanks. Internet now works!!! I added the network settings widget. I also changed from ifup to user controlled, and then i was able to connect with the widget. For other peoples reference, the user controlled vs ifup methods are found in network settings in yast under the “global options” tab. (I was running in KDE by the way)

Great
Well done

On 10/16/2012 01:06 AM, caf4926 wrote:
>
> rottweiler;2496369 Wrote:
>> Thanks. Internet now works!!! I added the network settings widget. I
>> also changed from ifup to user controlled, and then i was able to
>> connect with the widget. For other peoples reference, the user
>> controlled vs ifup methods are found in network settings in yast under
>> the “global options” tab. (I was running in KDE by the way)
> Great
> Well done

For anyone else reading this thread, the wireless had authenticated and
associated. That was shown by the fact that the iwconfig output showed an ESSID
and the MAC address of the AP. What was missing was the setup for DHCP, which
was shown by the lack of an IPv4 address in the ifconfig output. We do not know
if the routing was correct.

Establishing a wireless connection using ifup involves lots of details on
several different YaST screens, which is why using NetworkManager is
recommended, particularly for beginners. On those systems where I cannot use NM,
I always establish the connection using the /etc/sysconfig/network/ifcfg-wlanX
file using the template in that directory as a starting point.